aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-bsp/alsa-state/alsa-state.bb6
-rwxr-xr-xmeta/recipes-bsp/alsa-state/alsa-state/alsa-state-init (renamed from meta/recipes-bsp/alsa-state/alsa-state/alsa-state)0
2 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-bsp/alsa-state/alsa-state.bb b/meta/recipes-bsp/alsa-state/alsa-state.bb
index a9cc04c2a8..552fcfc022 100644
--- a/meta/recipes-bsp/alsa-state/alsa-state.bb
+++ b/meta/recipes-bsp/alsa-state/alsa-state.bb
@@ -15,7 +15,7 @@ PR = "r3"
SRC_URI = "\
file://asound.conf \
file://asound.state \
- file://alsa-state \
+ file://alsa-state-init \
"
inherit update-rc.d
@@ -24,9 +24,9 @@ INITSCRIPT_NAME = "alsa-state"
INITSCRIPT_PARAMS = "start 39 S . stop 31 0 6 ."
do_install() {
- sed -i -e "s:#STATEDIR#:${localstatedir}/lib/alsa:g" ${WORKDIR}/alsa-state
+ sed -i -e "s:#STATEDIR#:${localstatedir}/lib/alsa:g" ${WORKDIR}/alsa-state-init
install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/alsa-state ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/alsa-state-init ${D}${sysconfdir}/init.d/alsa-state
install -d ${D}/${localstatedir}/lib/alsa
install -m 0644 ${WORKDIR}/asound.conf ${D}${sysconfdir}
diff --git a/meta/recipes-bsp/alsa-state/alsa-state/alsa-state b/meta/recipes-bsp/alsa-state/alsa-state/alsa-state-init
index 9850791497..9850791497 100755
--- a/meta/recipes-bsp/alsa-state/alsa-state/alsa-state
+++ b/meta/recipes-bsp/alsa-state/alsa-state/alsa-state-init