summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-openmoko/packages/usbpath/usbpath-native_svn.bb8
-rw-r--r--meta-openmoko/packages/usbpath/usbpath_svn.bb18
2 files changed, 26 insertions, 0 deletions
diff --git a/meta-openmoko/packages/usbpath/usbpath-native_svn.bb b/meta-openmoko/packages/usbpath/usbpath-native_svn.bb
new file mode 100644
index 0000000000..3b5ef7bdcd
--- /dev/null
+++ b/meta-openmoko/packages/usbpath/usbpath-native_svn.bb
@@ -0,0 +1,8 @@
+require usbpath_svn.bb
+inherit native
+DEPENDS = "libusb-native"
+
+do_stage () {
+ autotools_stage_all
+}
+
diff --git a/meta-openmoko/packages/usbpath/usbpath_svn.bb b/meta-openmoko/packages/usbpath/usbpath_svn.bb
new file mode 100644
index 0000000000..0a06477b9a
--- /dev/null
+++ b/meta-openmoko/packages/usbpath/usbpath_svn.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Convert the physical locations of a USB device to/from its number"
+AUTHOR = "Werner Almesberger <werner@openmoko.org>"
+SECTION = "console/utils"
+LICENSE = "GPL"
+DEPENDS = "libusb"
+
+PV = "0.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host;module=usbpath;proto=http"
+
+S = "${WORKDIR}/usbpath"
+
+inherit autotools
+
+do_stage () {
+ autotools_stage_all
+}
+