summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/json-c/json-c/0001-Add-FALLTHRU-comment-to-handle-GCC7-warnings.patch74
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.13.bb (renamed from meta/recipes-devtools/json-c/json-c_0.12.1.bb)11
2 files changed, 5 insertions, 80 deletions
diff --git a/meta/recipes-devtools/json-c/json-c/0001-Add-FALLTHRU-comment-to-handle-GCC7-warnings.patch b/meta/recipes-devtools/json-c/json-c/0001-Add-FALLTHRU-comment-to-handle-GCC7-warnings.patch
deleted file mode 100644
index 537be5e6d2..0000000000
--- a/meta/recipes-devtools/json-c/json-c/0001-Add-FALLTHRU-comment-to-handle-GCC7-warnings.patch
+++ /dev/null
@@ -1,74 +0,0 @@
-From 7b24f8bd95ad4f7d00c93ca2ad998c14a0266dbe Mon Sep 17 00:00:00 2001
-From: marxin <mliska@suse.cz>
-Date: Tue, 21 Mar 2017 08:42:11 +0100
-Subject: [PATCH] Add FALLTHRU comment to handle GCC7 warnings.
-
----
-Upstream-Status: Backport
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
- json_object.c | 1 +
- json_tokener.c | 1 +
- linkhash.c | 22 +++++++++++-----------
- 3 files changed, 13 insertions(+), 11 deletions(-)
-
-diff --git a/json_object.c b/json_object.c
-index 6cc73bc..77e8b21 100644
---- a/json_object.c
-+++ b/json_object.c
-@@ -552,6 +552,7 @@ int64_t json_object_get_int64(struct json_object *jso)
- return jso->o.c_boolean;
- case json_type_string:
- if (json_parse_int64(jso->o.c_string.str, &cint) == 0) return cint;
-+ /* FALLTHRU */
- default:
- return 0;
- }
-diff --git a/json_tokener.c b/json_tokener.c
-index 9a76293..ae7b1ae 100644
---- a/json_tokener.c
-+++ b/json_tokener.c
-@@ -305,6 +305,7 @@ struct json_object* json_tokener_parse_ex(struct json_tokener *tok,
- tok->err = json_tokener_error_parse_unexpected;
- goto out;
- }
-+ /* FALLTHRU */
- case '"':
- state = json_tokener_state_string;
- printbuf_reset(tok->pb);
-diff --git a/linkhash.c b/linkhash.c
-index 712c387..74e3b0f 100644
---- a/linkhash.c
-+++ b/linkhash.c
-@@ -376,17 +376,17 @@ static uint32_t hashlittle( const void *key, size_t length, uint32_t initval)
- /*-------------------------------- last block: affect all 32 bits of (c) */
- switch(length) /* all the case statements fall through */
- {
-- case 12: c+=((uint32_t)k[11])<<24;
-- case 11: c+=((uint32_t)k[10])<<16;
-- case 10: c+=((uint32_t)k[9])<<8;
-- case 9 : c+=k[8];
-- case 8 : b+=((uint32_t)k[7])<<24;
-- case 7 : b+=((uint32_t)k[6])<<16;
-- case 6 : b+=((uint32_t)k[5])<<8;
-- case 5 : b+=k[4];
-- case 4 : a+=((uint32_t)k[3])<<24;
-- case 3 : a+=((uint32_t)k[2])<<16;
-- case 2 : a+=((uint32_t)k[1])<<8;
-+ case 12: c+=((uint32_t)k[11])<<24; /* FALLTHRU */
-+ case 11: c+=((uint32_t)k[10])<<16; /* FALLTHRU */
-+ case 10: c+=((uint32_t)k[9])<<8; /* FALLTHRU */
-+ case 9 : c+=k[8]; /* FALLTHRU */
-+ case 8 : b+=((uint32_t)k[7])<<24; /* FALLTHRU */
-+ case 7 : b+=((uint32_t)k[6])<<16; /* FALLTHRU */
-+ case 6 : b+=((uint32_t)k[5])<<8; /* FALLTHRU */
-+ case 5 : b+=k[4]; /* FALLTHRU */
-+ case 4 : a+=((uint32_t)k[3])<<24; /* FALLTHRU */
-+ case 3 : a+=((uint32_t)k[2])<<16; /* FALLTHRU */
-+ case 2 : a+=((uint32_t)k[1])<<8; /* FALLTHRU */
- case 1 : a+=k[0];
- break;
- case 0 : return c;
---
-2.12.2
-
diff --git a/meta/recipes-devtools/json-c/json-c_0.12.1.bb b/meta/recipes-devtools/json-c/json-c_0.13.bb
index 401cf13205..06319de323 100644
--- a/meta/recipes-devtools/json-c/json-c_0.12.1.bb
+++ b/meta/recipes-devtools/json-c/json-c_0.13.bb
@@ -5,18 +5,17 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
- file://0001-Add-FALLTHRU-comment-to-handle-GCC7-warnings.patch \
"
-SRC_URI[md5sum] = "55f7853f7d8cf664554ce3fa71bf1c7d"
-SRC_URI[sha256sum] = "2a136451a7932d80b7d197b10441e26e39428d67b1443ec43bbba824705e1123"
+SRC_URI[md5sum] = "11fc5d90c77375e5fc8401e8b9efbf21"
+SRC_URI[sha256sum] = "0316780be9ad16c42d7c26b015a784fd5df4b0909fef0aba51cfb13e492ac24d"
UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar"
# json-c releases page is fetching the list of releases in some weird XML format
# from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/
#UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html"
-RECIPE_UPSTREAM_VERSION = "0.12.1"
-RECIPE_UPSTREAM_DATE = "Jun 07, 2016"
-CHECK_DATE = "Apr 19, 2017"
+RECIPE_UPSTREAM_VERSION = "0.13"
+RECIPE_UPSTREAM_DATE = "Dec 07, 2017"
+CHECK_DATE = "Jan 31, 2018"
RPROVIDES_${PN} = "libjson"