summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/classes/gconf.bbclass1
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.3.bb7
2 files changed, 6 insertions, 2 deletions
diff --git a/meta/classes/gconf.bbclass b/meta/classes/gconf.bbclass
index 38097bc37a..cc01bcad2a 100644
--- a/meta/classes/gconf.bbclass
+++ b/meta/classes/gconf.bbclass
@@ -15,7 +15,6 @@ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL = "1"
gconf_postinst() {
if [ "x$D" != "x" ]; then
- export GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
export GCONF_CONFIG_SOURCE="xml::$D${sysconfdir}/gconf/gconf.xml.defaults"
else
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.3.bb b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
index f80c9104ed..ef21624de1 100644
--- a/meta/recipes-gnome/gnome/gconf_3.2.3.bb
+++ b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
@@ -9,7 +9,7 @@ POLKIT_libc-uclibc = ""
DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native ${POLKIT} gobject-introspection-stub"
DEPENDS_class-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native gobject-introspection-stub-native"
-PR = "r12"
+PR = "r13"
inherit gnomebase gtk-doc
@@ -37,6 +37,11 @@ do_install_append() {
rm -f ${D}${libdir}/gio/*/*.*a
}
+do_install_append_class-native() {
+ create_wrapper ${D}/${bindir}/gconftool-2 \
+ GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
+}
+
# disable dbus-x11 when x11 isn't in DISTRO_FEATURES
RDEPENDS_${PN} += "${@base_contains('DISTRO_FEATURES', 'x11', 'dbus-x11', '', d)}"
RDEPENDS_${PN}_class-native = ""