summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-graphics/mesa/files/0001-st-dri-Initialise-modifier-to-INVALID-for-DRI2.patch43
-rw-r--r--meta/recipes-graphics/mesa/mesa-gl_18.0.2.bb (renamed from meta/recipes-graphics/mesa/mesa-gl_17.3.8.bb)0
-rw-r--r--meta/recipes-graphics/mesa/mesa_18.0.2.bb (renamed from meta/recipes-graphics/mesa/mesa_17.3.8.bb)5
3 files changed, 2 insertions, 46 deletions
diff --git a/meta/recipes-graphics/mesa/files/0001-st-dri-Initialise-modifier-to-INVALID-for-DRI2.patch b/meta/recipes-graphics/mesa/files/0001-st-dri-Initialise-modifier-to-INVALID-for-DRI2.patch
deleted file mode 100644
index 6aba7859ee..0000000000
--- a/meta/recipes-graphics/mesa/files/0001-st-dri-Initialise-modifier-to-INVALID-for-DRI2.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 4cbecb61682a0ee426faaa03d824fc8fd7aef826 Mon Sep 17 00:00:00 2001
-From: Daniel Stone <daniels@collabora.com>
-Date: Mon, 2 Apr 2018 13:20:34 +0100
-Subject: [PATCH] st/dri: Initialise modifier to INVALID for DRI2
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-When allocating a buffer for DRI2, set the modifier to INVALID to inform
-the backend that we have no supplied modifiers and it should do its own
-thing. The missed initialisation forced linear, even if the
-implementation had made other decisions.
-
-This resulted in VC4 DRI2 clients failing with:
- Modifier 0x0 vs. tiling (0x700000000000001) mismatch
-
-Signed-off-by: Daniel Stone <daniels@collabora.com>
-Reported-by: Andreas Müller <schnitzeltony@gmail.com>
-Reviewed-by: Eric Anholt <eric@anholt.net>
-Fixes: 3f8513172ff6 ("gallium/winsys/drm: introduce modifier field to winsys_handle")
-
-Upstream-Status: Backport [1]
-
-[1] https://cgit.freedesktop.org/mesa/mesa/commit/?id=4cbecb61682a0ee426faaa03d824fc8fd7aef826
----
- src/gallium/state_trackers/dri/dri2.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/gallium/state_trackers/dri/dri2.c b/src/gallium/state_trackers/dri/dri2.c
-index 31d17d46c2..58a6757f03 100644
---- a/src/gallium/state_trackers/dri/dri2.c
-+++ b/src/gallium/state_trackers/dri/dri2.c
-@@ -806,6 +806,7 @@ dri2_allocate_textures(struct dri_context *ctx,
- whandle.handle = buf->name;
- whandle.stride = buf->pitch;
- whandle.offset = 0;
-+ whandle.modifier = DRM_FORMAT_MOD_INVALID;
- if (screen->can_share_buffer)
- whandle.type = DRM_API_HANDLE_TYPE_SHARED;
- else
---
-2.14.3
-
diff --git a/meta/recipes-graphics/mesa/mesa-gl_17.3.8.bb b/meta/recipes-graphics/mesa/mesa-gl_18.0.2.bb
index 73267eb4f0..73267eb4f0 100644
--- a/meta/recipes-graphics/mesa/mesa-gl_17.3.8.bb
+++ b/meta/recipes-graphics/mesa/mesa-gl_18.0.2.bb
diff --git a/meta/recipes-graphics/mesa/mesa_17.3.8.bb b/meta/recipes-graphics/mesa/mesa_18.0.2.bb
index 2d3fd3ca38..aaac1e58e1 100644
--- a/meta/recipes-graphics/mesa/mesa_17.3.8.bb
+++ b/meta/recipes-graphics/mesa/mesa_18.0.2.bb
@@ -8,11 +8,10 @@ SRC_URI = "https://mesa.freedesktop.org/archive/mesa-${PV}.tar.xz \
file://llvm-config-version.patch \
file://0001-winsys-svga-drm-Include-sys-types.h.patch \
file://0001-Makefile.vulkan.am-explictly-add-lib-expat-to-intel-.patch \
- file://0001-st-dri-Initialise-modifier-to-INVALID-for-DRI2.patch \
"
-SRC_URI[md5sum] = "203d1a79156ab6926f2d253b377e9d9d"
-SRC_URI[sha256sum] = "8f9d9bf281c48e4a8f5228816577263b4c655248dc7666e75034ab422951a6b1"
+SRC_URI[md5sum] = "3c303da98ec2ce37c795baeba5aee31e"
+SRC_URI[sha256sum] = "98fa159768482dc568b9f8bf0f36c7acb823fa47428ffd650b40784f16b9e7b3"
#because we cannot rely on the fact that all apps will use pkgconfig,
#make eglplatform.h independent of MESA_EGL_NO_X11_HEADER