summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/valgrind/valgrind/enable.building.on.4.x.kernel.patch37
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.10.1.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind/enable.building.on.4.x.kernel.patch b/meta/recipes-devtools/valgrind/valgrind/enable.building.on.4.x.kernel.patch
new file mode 100644
index 0000000000..300f2f19fa
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind/enable.building.on.4.x.kernel.patch
@@ -0,0 +1,37 @@
+Enable building valgrind on host with 4.x kernel.
+
+For OpenEmbedded builds we should be checking something like
+OLDEST_KERNEL instead of `uname -r`, but this is good enough for now.
+
+Building on 4.x* currently fails with:
+ configure:5556: checking for the kernel version
+ configure:5579: result: unsupported (4.0.0-rc3-00111-gaffb817)
+ configure:5581: error: Valgrind works on kernels 2.4, 2.6
+
+Upstream-Status: Pending
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+
+--- valgrind-3.9.0/configure.ac.orig 2015-03-13 19:17:01.247310868 +0100
++++ valgrind-3.9.0/configure.ac 2015-03-13 19:19:27.388316108 +0100
+@@ -276,9 +276,9 @@
+ kernel=`uname -r`
+
+ case "${kernel}" in
+- 2.6.*|3.*)
+- AC_MSG_RESULT([2.6.x/3.x family (${kernel})])
+- AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x or Linux 3.x])
++ 2.6.*|3.*|4.*)
++ AC_MSG_RESULT([2.6.x/3.x/4.x family (${kernel})])
++ AC_DEFINE([KERNEL_2_6], 1, [Define to 1 if you're using Linux 2.6.x or Linux 3.x or Linux 4.x])
+ ;;
+
+ 2.4.*)
+@@ -288,7 +288,7 @@
+
+ *)
+ AC_MSG_RESULT([unsupported (${kernel})])
+- AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6])
++ AC_MSG_ERROR([Valgrind works on kernels 2.4, 2.6, 3.x, 4.x])
+ ;;
+ esac
+
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb b/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
index 1c2ac61bbc..365e968549 100644
--- a/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
+++ b/meta/recipes-devtools/valgrind/valgrind_3.10.1.bb
@@ -21,6 +21,7 @@ SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
file://remove-arm-variant-specific.patch \
file://remove-ppc-tests-failing-build.patch \
file://valgrind-remove-rpath.patch \
+ file://enable.building.on.4.x.kernel.patch \
file://add-ptest.patch \
file://run-ptest \
"