aboutsummaryrefslogtreecommitdiffstats
path: root/meta-openmoko
diff options
context:
space:
mode:
Diffstat (limited to 'meta-openmoko')
-rw-r--r--meta-openmoko/packages/freesmartphone/gsmd2_git.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-openmoko/packages/freesmartphone/gsmd2_git.bb b/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
index 5983702d81..92e52b9bac 100644
--- a/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
+++ b/meta-openmoko/packages/freesmartphone/gsmd2_git.bb
@@ -6,7 +6,7 @@ DEPENDS = "dbus-native dbus dbus-glib"
RDEPENDS = "gsm0710muxd"
LICENSE = "GPL"
PV = "0.1.0+gitr${SRCREV}"
-PR = "r1"
+PR = "r2"
SRC_URI = "${FREESMARTPHONE_GIT}/gsmd2.git;protocol=git;branch=master \
file://fix-dbus-location.patch;patch=1"
@@ -17,9 +17,15 @@ inherit autotools
EXTRA_OECONF = "--disable-tests"
+do_install_append () {
+ install -d ${D}${sysconfdir}/gsmd2
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0644 ${S}/res/freesmartphone.conf ${D}${sysconfdir}/dbus-1/system.d/
+}
+
PACKAGES =+ "libgsmd2 libfreesmartphone"
FILES_libgsmd2 = "${libdir}/libgsmd2.so.* ${libdir}/gsmd2/*.so"
FILES_libfreesmartphone = "${libdir}/libfreesmartphone.so.*"
FILES_${PN}-dev += "${libdir}/gsmd2/*.*a"
-FILES_${PN} = "${bindir}/gsmd2"
+FILES_${PN} = "${bindir}/gsmd2 ${sysconfdir}/dbus-1/"