aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/qemu-config/qemu-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/qemu-config/qemu-config.bb')
-rw-r--r--meta/recipes-bsp/qemu-config/qemu-config.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-bsp/qemu-config/qemu-config.bb b/meta/recipes-bsp/qemu-config/qemu-config.bb
new file mode 100644
index 0000000000..fc59320282
--- /dev/null
+++ b/meta/recipes-bsp/qemu-config/qemu-config.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Adds scripts to use distcc on the host system under qemu"
+LICENSE = "GPL"
+RDEPENDS = "distcc task-poky-nfs-server oprofileui-server rsync bash"
+PR = "r17"
+
+SRC_URI = "file://distcc.sh \
+ file://anjuta-remote-run \
+ file://exports \
+ file://shutdown.desktop \
+ file://qemu-autostart"
+
+S = "${WORKDIR}"
+
+COMPATIBLE_MACHINE = "(qemuarm|qemux86)"
+PACKAGE_ARCH = "all"
+
+do_install() {
+ install -d ${D}${sysconfdir}/profile.d
+
+ install -m 0755 distcc.sh ${D}${sysconfdir}/profile.d/
+ install -m 0644 exports ${D}${sysconfdir}/
+
+ install -d ${D}${bindir}
+ install -m 0755 anjuta-remote-run ${D}${bindir}/
+
+ install -d ${D}${datadir}/applications
+ install -m 0644 shutdown.desktop ${D}${datadir}/applications/
+
+ install -d ${D}/etc/init.d
+ install qemu-autostart ${D}/etc/init.d/
+}
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "qemu-autostart"
+INITSCRIPT_PARAMS = "start 999 5 2 . stop 20 0 1 6 ."