summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/json-c/json-c_0.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/json-c/json-c_0.11.bb')
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.11.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.11.bb b/meta/recipes-devtools/json-c/json-c_0.11.bb
new file mode 100644
index 0000000000..831f281b69
--- /dev/null
+++ b/meta/recipes-devtools/json-c/json-c_0.11.bb
@@ -0,0 +1,20 @@
+SUMMARY = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C"
+HOMEPAGE = "https://github.com/json-c/json-c/wiki"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
+
+SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz"
+
+SRC_URI[md5sum] = "aa02367d2f7a830bf1e3376f77881e98"
+SRC_URI[sha256sum] = "28dfc65145dc0d4df1dfe7701ac173c4e5f9347176c8983edbfac9149494448c"
+
+RPROVIDES_${PN} = "libjson"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+do_configure_prepend() {
+ # Clean up autoconf cruft that should not be in the tarball
+ rm ${S}/config.status
+}