aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb')
-rw-r--r--meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb b/meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb
new file mode 100644
index 0000000000..d879782b29
--- /dev/null
+++ b/meta/recipes-devtools/unifdef/unifdef-native_2.6.18+git.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Kernel header preprocessor"
+SECTION = "devel"
+LICENSE = "GPL"
+
+SRC_URI = "file://unifdef.c"
+
+inherit native
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o unifdef ${WORKDIR}/unifdef.c
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 unifdef ${D}${bindir}
+}
+