aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind/valgrind-3.6.0
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind-3.6.0')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind-3.6.0/fix_issue_caused_by_ccache.patch30
-rw-r--r--meta/recipes-devtools/valgrind/valgrind-3.6.0/fixed-perl-path.patch51
2 files changed, 81 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind-3.6.0/fix_issue_caused_by_ccache.patch b/meta/recipes-devtools/valgrind/valgrind-3.6.0/fix_issue_caused_by_ccache.patch
new file mode 100644
index 0000000000..a5c273c45b
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind-3.6.0/fix_issue_caused_by_ccache.patch
@@ -0,0 +1,30 @@
+The script does not expect use of ccache, hence fix it to recognise it.
+
+2010/08/17
+Nitin A Kamble <nitin.a.kamble@intel.com>
+
+Index: valgrind-3.5.0/coregrind/link_tool_exe_linux.in
+===================================================================
+--- valgrind-3.5.0.orig/coregrind/link_tool_exe_linux.in
++++ valgrind-3.5.0/coregrind/link_tool_exe_linux.in
+@@ -62,6 +62,11 @@ die "Bogus alt-load address"
+
+ # The cc invokation to do the final link
+ my $cc = $ARGV[1];
++my $next = 2;
++if ("$cc" eq "ccache") {
++ $cc = "$cc $ARGV[2]";
++ $next = 3;
++}
+
+ # and the 'restargs' are argv[2 ..]
+
+@@ -71,7 +76,7 @@ my $cc = $ARGV[1];
+ my $cmd="$cc -static -Wl,-Ttext=$ala";
+
+ # Add the rest of the parameters
+-foreach my $n (2 .. $#ARGV) {
++foreach my $n ($next .. $#ARGV) {
+ $cmd = "$cmd $ARGV[$n]";
+ }
+
diff --git a/meta/recipes-devtools/valgrind/valgrind-3.6.0/fixed-perl-path.patch b/meta/recipes-devtools/valgrind/valgrind-3.6.0/fixed-perl-path.patch
new file mode 100644
index 0000000000..2a0440a1b0
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind-3.6.0/fixed-perl-path.patch
@@ -0,0 +1,51 @@
+this is a temporary patch to workaround cross compilation.
+otherwise @PERL@ will be replaced to perl-native binary,
+this creates unusable scripts and fails FILERDEPENDS mechanism
+(esp. rpm)
+
+a better fix would need:
+ 1. configure.ac should differentiate PERL and HOSTPERL
+ 2. optionally remove ${STAGING_DIR} in #! line before do_install
+
+8/31/2010 - created by Qing He <qing.he@intel.com>
+
+diff --git a/cachegrind/cg_annotate.in b/cachegrind/cg_annotate.in
+index 9dc9565..cc4ef05 100644
+--- a/cachegrind/cg_annotate.in
++++ b/cachegrind/cg_annotate.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+
+ ##--------------------------------------------------------------------##
+ ##--- Cachegrind's annotator. cg_annotate.in ---##
+diff --git a/cachegrind/cg_diff.in b/cachegrind/cg_diff.in
+index 951066e..84c2dde 100644
+--- a/cachegrind/cg_diff.in
++++ b/cachegrind/cg_diff.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+
+ ##--------------------------------------------------------------------##
+ ##--- Cachegrind's differencer. cg_diff.in ---##
+diff --git a/massif/ms_print.in b/massif/ms_print.in
+index e6ffdbf..fb45906 100755
+--- a/massif/ms_print.in
++++ b/massif/ms_print.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+
+ ##--------------------------------------------------------------------##
+ ##--- Massif's results printer ms_print.in ---##
+diff --git a/perf/vg_perf.in b/perf/vg_perf.in
+index 2188a31..83ad024 100644
+--- a/perf/vg_perf.in
++++ b/perf/vg_perf.in
+@@ -1,4 +1,4 @@
+-#! @PERL@
++#! /usr/bin/perl
+ ##--------------------------------------------------------------------##
+ ##--- Valgrind performance testing script vg_perf ---##
+ ##--------------------------------------------------------------------##