aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/pseudo/files/0001-Don-t-send-SIGUSR1-to-init.patch48
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_1.8.1.bb1
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb2
3 files changed, 50 insertions, 1 deletions
diff --git a/meta/recipes-devtools/pseudo/files/0001-Don-t-send-SIGUSR1-to-init.patch b/meta/recipes-devtools/pseudo/files/0001-Don-t-send-SIGUSR1-to-init.patch
new file mode 100644
index 0000000000..6c694ceb0d
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/files/0001-Don-t-send-SIGUSR1-to-init.patch
@@ -0,0 +1,48 @@
+From befc6dbd6469d428c9e0830dbe51bdf7ac39d9ae Mon Sep 17 00:00:00 2001
+From: Seebs <seebs@seebs.net>
+Date: Thu, 22 Sep 2016 14:35:04 -0500
+Subject: [PATCH] Don't send SIGUSR1 to init.
+
+If the parent exits due to child process being slow, getppid() will return
+1, and we'll send SIGUSR1 to init, which can break things like dumbinit
+which aren't adequately protected against non-root processes sending them
+signals.
+
+Signed-off-by: Seebs <seebs@seebs.net>
+
+Upstream-Status: Backport (commit befc6dbd6469d428c9e0830dbe51bdf7ac39d9ae)
+
+[YOCTO #10324]
+
+This resolves an issue where a docker container running builds would die
+due to it's 'mini init' being signaled by pseudo.
+
+Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
+---
+ pseudo_server.c | 11 ++++++++---
+
+diff --git a/pseudo_server.c b/pseudo_server.c
+index 65102dd..8731d20 100644
+--- a/pseudo_server.c
++++ b/pseudo_server.c
+@@ -358,9 +358,14 @@ pseudo_server_start(int daemonize) {
+ signal(SIGTERM, quit_now);
+ /* tell parent process to stop waiting */
+ if (daemonize) {
+- pseudo_diag("Setup complete, sending SIGUSR1 to pid %d.\n",
+- getppid());
+- kill(getppid(), SIGUSR1);
++ pid_t ppid = getppid();
++ if (ppid == 1) {
++ pseudo_diag("Setup complete, but parent is init, not sending SIGUSR1.\n");
++ } else {
++ pseudo_diag("Setup complete, sending SIGUSR1 to pid %d.\n",
++ ppid);
++ kill(ppid, SIGUSR1);
++ }
+ }
+ pseudo_server_loop();
+ return 0;
+--
+2.5.5
+
diff --git a/meta/recipes-devtools/pseudo/pseudo_1.8.1.bb b/meta/recipes-devtools/pseudo/pseudo_1.8.1.bb
index f45912a711..cec214986e 100644
--- a/meta/recipes-devtools/pseudo/pseudo_1.8.1.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_1.8.1.bb
@@ -6,6 +6,7 @@ SRC_URI = "http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz
file://fallback-group \
file://moreretries.patch \
file://Fix-xattr-performance.patch \
+ file://0001-Don-t-send-SIGUSR1-to-init.patch \
"
SRC_URI[md5sum] = "ee38e4fb62ff88ad067b1a5a3825bac7"
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index 8735cf405a..8110b1a193 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -1,6 +1,6 @@
require pseudo.inc
-SRCREV = "f4b1c752186f4d08f1fadb0ea10ebcde9b0ea251"
+SRCREV = "befc6dbd6469d428c9e0830dbe51bdf7ac39d9ae"
PV = "1.8.1+git${SRCPV}"
DEFAULT_PREFERENCE = "-1"