summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libaio/libaio/toolchain.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libaio/libaio/toolchain.patch')
-rw-r--r--meta/recipes-extended/libaio/libaio/toolchain.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/libaio/libaio/toolchain.patch b/meta/recipes-extended/libaio/libaio/toolchain.patch
new file mode 100644
index 0000000000..ae400cf857
--- /dev/null
+++ b/meta/recipes-extended/libaio/libaio/toolchain.patch
@@ -0,0 +1,25 @@
+8/27/2010 - created by Qing He <qing.he@intel.com>
+
+diff --git a/src/Makefile b/src/Makefile
+index 8d134cc..df8e5b6 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -2,7 +2,6 @@ prefix=/usr
+ includedir=$(prefix)/include
+ libdir=$(prefix)/lib
+
+-ARCH := $(shell uname -m | sed -e s/i.86/i386/)
+ CFLAGS := -nostdlib -nostartfiles -Wall -I. -g -fomit-frame-pointer -O2 -fPIC
+ SO_CFLAGS=-shared $(CFLAGS)
+ L_CFLAGS=$(CFLAGS)
+@@ -44,8 +43,8 @@ $(libaio_objs) $(libaio_sobjs): libaio.h vsys_def.h
+
+ libaio.a: $(libaio_objs)
+ rm -f libaio.a
+- ar r libaio.a $^
+- ranlib libaio.a
++ $(AR) r libaio.a $^
++ $(RANLIB) libaio.a
+
+ $(libname): $(libaio_sobjs) libaio.map
+ $(CC) $(SO_CFLAGS) -Wl,--version-script=libaio.map -Wl,-soname=$(soname) -o $@ $(libaio_sobjs) $(LINK_FLAGS)