summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsof/lsof_4.86.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lsof/lsof_4.86.bb')
-rw-r--r--meta/recipes-extended/lsof/lsof_4.86.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.86.bb b/meta/recipes-extended/lsof/lsof_4.86.bb
new file mode 100644
index 0000000000..e3f5ef387f
--- /dev/null
+++ b/meta/recipes-extended/lsof/lsof_4.86.bb
@@ -0,0 +1,54 @@
+SUMMARY = "LiSt Open Files tool"
+DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
+Its name stands for LiSt Open Files, and it does just that."
+SECTION = "devel"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "9f1cda41f35add068c7b81f873fa56b5"
+SRC_URI[sha256sum] = "13e52b8e87dddf1b2e219004e315d755c659217ce6ffc6a5f1102969f1c4dd0c"
+
+LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
+S = "${WORKDIR}/lsof_${PV}_src"
+
+LIC_FILES_CHKSUM = "file://${S}/00README;beginline=645;endline=679;md5=964df275d26429ba3b39dbb9f205172a"
+
+python do_unpack () {
+ bb.build.exec_func('base_do_unpack', d)
+ src_uri = d.getVar('SRC_URI')
+ d.setVar('SRC_URI', '${LOCALSRC}')
+ bb.build.exec_func('base_do_unpack', d)
+ d.setVar('SRC_URI', src_uri)
+}
+
+export LSOF_OS = "${TARGET_OS}"
+LSOF_OS_libc-uclibc = "linux"
+LSOF_OS_libc-glibc = "linux"
+export LSOF_INCLUDE = "${STAGING_INCDIR}"
+
+do_configure () {
+ export LSOF_AR="${AR} cr"
+ export LSOF_RANLIB="${RANLIB}"
+ if [ "x${EGLIBCVERSION}" != "x" ];then
+ LINUX_CLIB=`echo ${EGLIBCVERSION} |sed -e 's,\.,,g'`
+ LINUX_CLIB="-DGLIBCV=${LINUX_CLIB}"
+ export LINUX_CLIB
+ fi
+ yes | ./Configure ${LSOF_OS}
+}
+
+export I = "${STAGING_INCDIR}"
+export L = "${STAGING_INCDIR}"
+export EXTRA_OEMAKE = ""
+
+do_compile () {
+ oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
+}
+
+do_install () {
+ install -d ${D}${sbindir} ${D}${mandir}/man8
+ install -m 4755 lsof ${D}${sbindir}/lsof
+ install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
+}