aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.6.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
index 43b462ad8c..e0c710b038 100644
--- a/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.6.bb
@@ -24,6 +24,8 @@ inherit autotools update-alternatives
ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_${PN} = "bunzip2 bzcat"
+#install binaries to bzip2-native under sysroot for replacement-native
+EXTRA_OECONF_virtclass-native += "--bindir=${STAGING_BINDIR_NATIVE}/${PN}"
do_configure_prepend () {
cp ${WORKDIR}/configure.ac ${S}/
cp ${WORKDIR}/Makefile.am ${S}/
@@ -40,5 +42,5 @@ FILES_libbz2-staticdev = "${libdir}/*.a"
SECTION_libbz2-staticdev = "devel"
RDEPENDS_libbz2-staticdev = "libbz2-dev (= ${EXTENDPKGV})"
-PROVIDES_append_virtclass-native = " bzip2-full-native"
+PROVIDES_append_virtclass-native = " bzip2-replacement-native"
BBCLASSEXTEND = "native"