aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome/gobject-introspection_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome/gobject-introspection_git.bb')
-rw-r--r--meta/recipes-gnome/gnome/gobject-introspection_git.bb32
1 files changed, 18 insertions, 14 deletions
diff --git a/meta/recipes-gnome/gnome/gobject-introspection_git.bb b/meta/recipes-gnome/gnome/gobject-introspection_git.bb
index 5e37255285..83523845d8 100644
--- a/meta/recipes-gnome/gnome/gobject-introspection_git.bb
+++ b/meta/recipes-gnome/gnome/gobject-introspection_git.bb
@@ -1,29 +1,33 @@
-SRC_URI = "git://git.gnome.org/gobject-introspection;protocol=git \
- file://configure.patch \
- file://pathfix.patch"
+# NOTE: WIP! This recipe does not cross-compile atm., only -native
+DEPENDS = "glib-2.0 libffi python-native gobject-introspection-native"
+DEPENDS_virtclass-native = "glib-2.0-native libffi-native python-native bison-native flex-native"
+BBCLASSEXTEND = "native"
-SRC_URI_virtclass-native = "git://git.gnome.org/gobject-introspection;protocol=git \
- file://pathfix.patch"
+SRC_URI = "git://git.gnome.org/gobject-introspection;protocol=git \
+ file://use-usr-bin-env-for-python.patch \
+"
LICENSE = "GPLv2+ & LGPLv2+"
LIC_FILES_CHKSUM = "file://COPYING.tools;md5=94d55d512a9ba36caa9b7df079bae19f \
file://COPYING.lib;md5=3bf50002aefd002f49e7bb854063f7e7"
-SRCREV = "efa7266bcf78478ce62e8dd778a4f0417bfd4d15"
-PV = "0.10.8+git${SRCPV}"
-PR = "r4"
+SRCREV = "8d64bc23d2b837421ecf9c7b0e4b8d5d95ca0d21"
+PV = "1.29.0+gitr${SRCPV}"
+DEFAULT_PREFERENCE = "-1"
S = "${WORKDIR}/git"
-DEPENDS = "libffi python-native gobject-introspection-native"
-DEPENDS_virtclass-native = "libffi-native python-native bison-native flex-native"
-
inherit autotools
-TARGET_CFLAGS += "-I${STAGING_INCDIR_NATIVE}/python2.5"
+BBCLASSEXTEND = "native"
do_configure_prepend () {
- echo "EXTRA_DIST = " > ${S}/gtk-doc.make
+ echo "EXTRA_DIST = " > ${S}/gtk-doc.make
}
-BBCLASSEXTEND = "native"
+EXTRA_OECONF = "\
+ --disable-gtk-doc \
+ --disable-gtk-doc-html \
+ --disable-gtk-doc-pdf \
+ --disable-tests \
+"