aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome/gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-gnome/gnome')
-rw-r--r--meta/recipes-gnome/gnome/gconf_3.2.3.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-gnome/gnome/gconf_3.2.3.bb b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
index 412f01c86f..a0b8d0c632 100644
--- a/meta/recipes-gnome/gnome/gconf_3.2.3.bb
+++ b/meta/recipes-gnome/gnome/gconf_3.2.3.bb
@@ -3,10 +3,13 @@ SECTION = "x11/gnome"
LICENSE = "LGPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
-DEPENDS = "glib-2.0 gtk+ dbus dbus-glib libxml2 intltool-native polkit"
+POLKIT = "polkit"
+POLKIT_libc-uclibc = ""
+
+DEPENDS = "glib-2.0 gtk+ dbus dbus-glib libxml2 intltool-native ${POLKIT}"
DEPENDS_virtclass-native = "glib-2.0-native dbus-native dbus-glib-native libxml2-native intltool-native gnome-common-native"
-PR = "r5"
+PR = "r6"
inherit gnomebase
@@ -21,6 +24,8 @@ S = "${WORKDIR}/GConf-${PV}"
POLKIT_OECONF = "--enable-defaults-service"
POLKIT_OECONF_virtclass-native = "--disable-defaults-service"
+POLKIT_OECONF_libc-uclibc = "--disable-default-service"
+
GTKOECONF = "--with-gtk=2.0 --enable-gtk"
GTKOECONF_virtclass-native = "--disable-gtk"
EXTRA_OECONF = "--disable-gtk-doc --enable-shared --disable-static --enable-debug=yes \