summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/clutter/clutter-cairo/enable_examples.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/clutter/clutter-cairo/enable_examples.patch')
-rw-r--r--meta/recipes-graphics/clutter/clutter-cairo/enable_examples.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-graphics/clutter/clutter-cairo/enable_examples.patch b/meta/recipes-graphics/clutter/clutter-cairo/enable_examples.patch
new file mode 100644
index 0000000000..c5ed63ff12
--- /dev/null
+++ b/meta/recipes-graphics/clutter/clutter-cairo/enable_examples.patch
@@ -0,0 +1,28 @@
+---
+ examples/Makefile.am | 2 +-
+ examples/flowers.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: clutter-cairo/examples/Makefile.am
+===================================================================
+--- clutter-cairo.orig/examples/Makefile.am 2008-08-11 16:30:04.000000000 +0100
++++ clutter-cairo/examples/Makefile.am 2008-08-11 16:30:24.000000000 +0100
+@@ -1,4 +1,4 @@
+-noinst_PROGRAMS = clock flowers bubbles
++bin_PROGRAMS = clock flowers bubbles
+
+ INCLUDES = -I$(top_srcdir)/ @GCC_FLAGS@ @DEPS_CFLAGS@
+ AM_LDFLAGS = @DEPS_LIBS@ $(top_builddir)/libclutter-cairo-@CLUTTER_CAIRO_MAJORMINOR@.la
+Index: clutter-cairo/examples/flowers.c
+===================================================================
+--- clutter-cairo.orig/examples/flowers.c 2008-08-11 16:30:04.000000000 +0100
++++ clutter-cairo/examples/flowers.c 2008-08-11 16:30:10.000000000 +0100
+@@ -11,7 +11,7 @@
+
+ #define PETAL_MIN 20
+ #define PETAL_VAR 40
+-#define N_FLOWERS 40 /* reduce if you have a small card */
++#define N_FLOWERS 8 /* reduce if you have a small card */
+
+ typedef struct Flower
+ {