aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mx/mx/fix-test-includes.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/mx/mx/fix-test-includes.patch')
-rw-r--r--meta/recipes-graphics/mx/mx/fix-test-includes.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mx/mx/fix-test-includes.patch b/meta/recipes-graphics/mx/mx/fix-test-includes.patch
new file mode 100644
index 0000000000..c6496a97af
--- /dev/null
+++ b/meta/recipes-graphics/mx/mx/fix-test-includes.patch
@@ -0,0 +1,20 @@
+Fix missing include directory when building tests
+
+This patch is currently required for all versions of mx
+Upstream-status: Submitted @ https://github.com/clutter-project/mx/issues/82
+Signed-off-by: Tomas Frydrych <tomas@sleepfive.com>
+--
+Index: git/tests/Makefile.am
+===================================================================
+--- git.orig/tests/Makefile.am 2013-05-08 15:18:56.918596425 +0100
++++ git/tests/Makefile.am 2013-05-08 15:23:26.864781401 +0100
+@@ -10,7 +10,8 @@
+
+ INCLUDES = \
+ -I$(top_srcdir) \
+- -I$(top_builddir)
++ -I$(top_builddir)\
++ -I$(top_builddir)/mx
+
+ noinst_PROGRAMS = \
+ test-deform-texture \