summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb')
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
new file mode 100644
index 0000000000..a850a2d42a
--- /dev/null
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.85.bb
@@ -0,0 +1,24 @@
+pickDESCRIPTION = "Python hardware latency detector"
+HOMEPAGE = "http://git.kernel.org/?p=linux/kernel/git/clrkwllms/rt-tests.git"
+SECTION = "tests"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+RDEPENDS = "python python-subprocess python-textutils"
+RRECOMMENDS_${PN} = "kernel-module-hwlat-detector"
+
+require rt-tests.inc
+
+PR = "${INC_PR}.0"
+
+EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"
+
+do_compile() {
+ oe_runmake hwlatdetect
+}
+
+do_install() {
+ oe_runmake install_hwlatdetect DESTDIR=${D} SBINDIR=${sbindir} \
+ MANDIR=${mandir} INCLUDEDIR=${includedir}
+}
+
+FILES_${PN} += "${libdir}/python${PYTHON_BASEVERSION}/dist-packages/hwlatdetect.py"