summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/matchbox-desktop
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/matchbox-desktop')
-rw-r--r--meta/recipes-sato/matchbox-desktop/matchbox-desktop_0.9.1.bb24
-rw-r--r--meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.0.bb11
-rw-r--r--meta/recipes-sato/matchbox-desktop/matchbox-desktop_svn.bb22
3 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_0.9.1.bb b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_0.9.1.bb
new file mode 100644
index 0000000000..0a02bb9f3d
--- /dev/null
+++ b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_0.9.1.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Matchbox Window Manager Desktop"
+LICENSE = "GPL"
+DEPENDS = "libmatchbox startup-notification"
+SECTION = "x11/wm"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-desktop/0.9/matchbox-desktop-${PV}.tar.bz2"
+
+EXTRA_OECONF = "--enable-startup-notification --enable-dnotify"
+
+inherit autotools pkgconfig
+
+FILES_${PN} = "${bindir}/* \
+ ${datadir}/applications \
+ ${libdir}/matchbox/desktop/*.so \
+ ${datadir}/matchbox-desktop \
+ ${datadir}/pixmaps \
+ ${sysconfdir}/matchbox"
+
+FILES_${PN}-dev += "${libdir}/matchbox-desktop \
+ ${includedir}/matchbox-desktop \
+ ${libdir}/matchbox/desktop/*.*a \
+ ${datadir}/matchbox/desktop/modules/*a"
+
+FILES_${PN}-dbg += "${libdir}/matchbox/desktop/.debug/"
diff --git a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.0.bb b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.0.bb
new file mode 100644
index 0000000000..83d4d0b3fd
--- /dev/null
+++ b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_2.0.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Matchbox Window Manager Desktop"
+LICENSE = "GPL"
+DEPENDS = "gtk+ startup-notification"
+SECTION = "x11/wm"
+PR = "r1"
+
+SRC_URI = "http://projects.o-hand.com/matchbox/sources/matchbox-desktop/2.0/matchbox-desktop-${PV}.tar.bz2"
+
+EXTRA_OECONF = "--enable-startup-notification"
+
+inherit autotools pkgconfig
diff --git a/meta/recipes-sato/matchbox-desktop/matchbox-desktop_svn.bb b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_svn.bb
new file mode 100644
index 0000000000..324c81ff27
--- /dev/null
+++ b/meta/recipes-sato/matchbox-desktop/matchbox-desktop_svn.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Matchbox Window Manager Desktop"
+HOMEPAGE = "http://matchbox-project.org/"
+BUGTRACKER = "http://bugzilla.openedhand.com/"
+
+LICENSE = "GPLv2+ & LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://libtaku/eggsequence.h;endline=20;md5=b91f68f7642a1459fa1f4c9df94a8f15 \
+ file://src/desktop.c;endline=20;md5=36c9bf295e6007f3423095f405af5a2d \
+ file://src/main.c;endline=19;md5=2044244f97a195c25b7dc602ac7e9a00"
+
+DEPENDS = "gtk+ startup-notification dbus"
+SECTION = "x11/wm"
+PV = "2.0+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "svn://svn.o-hand.com/repos/matchbox/trunk;module=${PN}-2;proto=http"
+
+EXTRA_OECONF = "--enable-startup-notification --with-dbus"
+
+S = "${WORKDIR}/${PN}-2"
+
+inherit autotools pkgconfig