aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/rxvt-unicode/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/rxvt-unicode/files')
-rw-r--r--meta/recipes-sato/rxvt-unicode/files/makefile.patch20
-rw-r--r--meta/recipes-sato/rxvt-unicode/files/rxvt.desktop11
-rw-r--r--meta/recipes-sato/rxvt-unicode/files/rxvt.pngbin0 -> 2847 bytes
-rw-r--r--meta/recipes-sato/rxvt-unicode/files/signedchar.patch11
-rw-r--r--meta/recipes-sato/rxvt-unicode/files/xwc.patch28
5 files changed, 70 insertions, 0 deletions
diff --git a/meta/recipes-sato/rxvt-unicode/files/makefile.patch b/meta/recipes-sato/rxvt-unicode/files/makefile.patch
new file mode 100644
index 0000000000..86f82eeb4c
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/files/makefile.patch
@@ -0,0 +1,20 @@
+--- ../rxvt-unicode-cvs-r0/rxvt-unicode/Makefile.in 2004-08-12 22:32:40 +01:00
++++ rxvt-unicode/Makefile.in 2004-12-24 03:09:00 +00:00
+@@ -9,7 +9,7 @@
+ first_rule: all
+ dummy:
+
+-subdirs = src doc src/test
++subdirs = src src/test
+ allsubdirs = W11 $(subdirs)
+
+ DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
+@@ -24,7 +24,7 @@
+
+ #-------------------------------------------------------------------------
+
+-all allbin alldoc tags:
++all allbin tags:
+ @if test x@host_os@ = xcygwin; then (cd W11; ${MAKE} $@) || exit 1; fi
+ @for I in ${subdirs}; do (cd $$I; ${MAKE} $@) || exit 1; done
+
diff --git a/meta/recipes-sato/rxvt-unicode/files/rxvt.desktop b/meta/recipes-sato/rxvt-unicode/files/rxvt.desktop
new file mode 100644
index 0000000000..a419c98a13
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/files/rxvt.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Terminal
+Comment=When all else fails.
+Exec=/usr/bin/rxvt
+Icon=utilities-terminal.png
+Terminal=false
+Type=Application
+Categories=Utility
+StartupNotify=false
+
diff --git a/meta/recipes-sato/rxvt-unicode/files/rxvt.png b/meta/recipes-sato/rxvt-unicode/files/rxvt.png
new file mode 100644
index 0000000000..e56fa2e9cd
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/files/rxvt.png
Binary files differ
diff --git a/meta/recipes-sato/rxvt-unicode/files/signedchar.patch b/meta/recipes-sato/rxvt-unicode/files/signedchar.patch
new file mode 100644
index 0000000000..6faa175143
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/files/signedchar.patch
@@ -0,0 +1,11 @@
+--- ../rxvt-unicode-cvs-r0/rxvt-unicode/src/command.C 2004-12-21 06:43:00 +00:00
++++ rxvt-unicode/src/command.C 2004-12-24 02:31:36 +00:00
+@@ -1862,7 +1862,7 @@
+ #endif /* NO_SCROLLBAR_REPORT */
+
+ {
+- char upordown = 0;
++ signed char upordown = 0;
+
+ if (scrollBar.style == R_SB_NEXT)
+ {
diff --git a/meta/recipes-sato/rxvt-unicode/files/xwc.patch b/meta/recipes-sato/rxvt-unicode/files/xwc.patch
new file mode 100644
index 0000000000..7cf59656ce
--- /dev/null
+++ b/meta/recipes-sato/rxvt-unicode/files/xwc.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- rxvt-unicode-4.8/src/screen.C~xwc.c
++++ rxvt-unicode-4.8/src/screen.C
+@@ -3058,7 +3058,7 @@
+ else
+ rxvt_warn ("can't get primary selection, ignoring.\n");
+
+-#if 0
++#ifdef HAVE_XWC
+ XTextProperty ct;
+
+ if (XwcTextListToTextProperty (display->display, &selection.text, 1, XStringStyle, &ct) >= 0)
+@@ -3632,9 +3632,11 @@
+ }
+ else
+ #endif
++#ifdef HAVE_XWC
+ if (XwcTextListToTextProperty (display->display, &cl, 1, (XICCEncodingStyle) style, &ct) >= 0)
+ freect = 1;
+ else
++#endif
+ {
+ /* if we failed to convert then send it raw */
+ ct.value = (unsigned char *)cl;