aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/sato-screenshot
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/sato-screenshot')
-rw-r--r--meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb b/meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb
index a079e03d97..8794032d25 100644
--- a/meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb
+++ b/meta/recipes-sato/sato-screenshot/sato-screenshot_git.bb
@@ -16,7 +16,7 @@ SRC_URI = "git://git.yoctoproject.org/screenshot"
S = "${WORKDIR}/git"
-inherit autotools pkgconfig
+inherit autotools pkgconfig distro_features_check
FILES_${PN} += "${libdir}/matchbox-panel/*.so"
FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"
@@ -24,3 +24,6 @@ FILES_${PN}-dbg += "${libdir}/matchbox-panel/.debug"
do_install_append () {
rm ${D}${libdir}/matchbox-panel/*.la
}
+
+# The matchbox-panel-2 requires x11 in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES = "x11"