aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb')
-rw-r--r--meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
index d0f507e673..c5096c1530 100644
--- a/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
+++ b/meta/recipes-sato/shutdown-desktop/shutdown-desktop.bb
@@ -5,6 +5,8 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
SRC_URI = "file://shutdown.desktop"
+PR = "r1"
+
S = "${WORKDIR}"
do_install() {
@@ -14,7 +16,8 @@ do_install() {
pkg_postinst_${PN} () {
grep -q qemuarm $D${sysconfdir}/hostname && \
- sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/'
+ sed -i $D${datadir}/applications/shutdown.desktop -e 's/^Exec=halt/Exec=reboot/' \
+ || true
}
inherit allarch