summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.73.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.73.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.73.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.73.0.bb b/meta/recipes-support/boost/bjam-native_1.73.0.bb
new file mode 100644
index 0000000000..d843eb038c
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.73.0.bb
@@ -0,0 +1,20 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \
+ file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \
+ "
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 b2 ${D}${bindir}/bjam
+}