summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/enchant/enchant2_2.2.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/enchant/enchant2_2.2.15.bb')
-rw-r--r--meta/recipes-support/enchant/enchant2_2.2.15.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/enchant/enchant2_2.2.15.bb b/meta/recipes-support/enchant/enchant2_2.2.15.bb
new file mode 100644
index 0000000000..05e84fc726
--- /dev/null
+++ b/meta/recipes-support/enchant/enchant2_2.2.15.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Enchant Spell checker API Library"
+SECTION = "libs"
+HOMEPAGE = "https://abiword.github.io/enchant/"
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS = "glib-2.0"
+
+inherit autotools pkgconfig
+
+SRC_URI = "https://github.com/AbiWord/enchant/releases/download/v${PV}/enchant-${PV}.tar.gz"
+SRC_URI[sha256sum] = "3b0f2215578115f28e2a6aa549b35128600394304bd79d6f28b0d3b3d6f46c03"
+
+UPSTREAM_CHECK_URI = "https://github.com/AbiWord/enchant/releases"
+
+S = "${WORKDIR}/enchant-${PV}"
+
+EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2"
+
+PACKAGECONFIG ??= "aspell"
+PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell"
+PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell"
+
+FILES_${PN} += " \
+ ${datadir}/enchant-2 \
+ ${libdir}/enchant-2 \
+"
+FILES_${PN}-staticdev += "${libdir}/enchant-2/*.a"