aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgpg-error/libgpg-error-1.8/pkgconfig.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libgpg-error/libgpg-error-1.8/pkgconfig.patch')
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error-1.8/pkgconfig.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-support/libgpg-error/libgpg-error-1.8/pkgconfig.patch b/meta/recipes-support/libgpg-error/libgpg-error-1.8/pkgconfig.patch
new file mode 100644
index 0000000000..49e47d874e
--- /dev/null
+++ b/meta/recipes-support/libgpg-error/libgpg-error-1.8/pkgconfig.patch
@@ -0,0 +1,53 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+Index: libgpg-error-1.8/configure.ac
+===================================================================
+--- libgpg-error-1.8.orig/configure.ac 2010-05-06 06:01:08.000000000 -0700
++++ libgpg-error-1.8/configure.ac 2010-07-21 02:20:20.923261305 -0700
+@@ -140,6 +140,7 @@
+ AC_SUBST(GPG_ERROR_CONFIG_CFLAGS)
+ AC_SUBST(GPG_ERROR_CONFIG_ISUBDIRAFTER)
+ AC_CONFIG_FILES([src/gpg-error-config], [chmod +x src/gpg-error-config])
++AC_CONFIG_FILES([src/gpg-error.pc])
+
+
+ # Special defines for certain platforms
+Index: libgpg-error-1.8/src/Makefile.am
+===================================================================
+--- libgpg-error-1.8.orig/src/Makefile.am 2010-04-14 02:16:44.000000000 -0700
++++ libgpg-error-1.8/src/Makefile.am 2010-07-21 02:22:36.655012496 -0700
+@@ -37,13 +37,15 @@
+ bin_SCRIPTS = gpg-error-config
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = gpg-error.m4
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = gpg-error.pc
+
+ EXTRA_DIST = mkstrtable.awk err-sources.h.in err-codes.h.in \
+ mkerrnos.awk errnos.in README \
+ mkerrcodes.awk mkerrcodes1.awk mkerrcodes2.awk mkerrcodes.c \
+ mkheader.awk gpg-error.h.in mkw32errmap.c w32-add.h w32ce-add.h \
+ err-sources.h err-codes.h gpg-error-config.in gpg-error.m4 \
+- gpg-error.def.in versioninfo.rc.in
++ gpg-error.def.in versioninfo.rc.in gpg-error.pc.in
+
+ BUILT_SOURCES = err-sources.h err-codes.h code-to-errno.h code-from-errno.h \
+ err-sources-sym.h err-codes-sym.h errnos-sym.h gpg-error.h \
+Index: libgpg-error-1.8/src/gpg-error.pc.in
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ libgpg-error-1.8/src/gpg-error.pc.in 2010-07-21 02:20:20.923261305 -0700
+@@ -0,0 +1,10 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: gpg-error
++Description: a library that defines common error values for all GnuPG components
++Version: @VERSION@
++Libs: -L{libdir} -lgpg-error
++Cflags: -I${includedir}