summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lzo/lzo_2.08.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/lzo/lzo_2.08.bb')
-rw-r--r--meta/recipes-support/lzo/lzo_2.08.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-support/lzo/lzo_2.08.bb b/meta/recipes-support/lzo/lzo_2.08.bb
new file mode 100644
index 0000000000..7d7d1f32ba
--- /dev/null
+++ b/meta/recipes-support/lzo/lzo_2.08.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Lossless data compression library"
+HOMEPAGE = "http://www.oberhumer.com/opensource/lzo/"
+SECTION = "libs"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://src/lzo_init.c;beginline=5;endline=25;md5=a6e25df9a83b24629e847846ccdd8054"
+
+SRC_URI = "http://www.oberhumer.com/opensource/lzo/download/lzo-${PV}.tar.gz \
+ file://acinclude.m4 \
+ "
+
+SRC_URI[md5sum] = "fcec64c26a0f4f4901468f360029678f"
+SRC_URI[sha256sum] = "ac1b3e4dee46febe9fd28737eb7f5692d3232ef1a01da10444394c3d47536614"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-shared"
+
+do_configure_prepend () {
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+}
+
+BBCLASSEXTEND = "native nativesdk"