aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ohm
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/ohm')
-rw-r--r--meta/recipes-support/ohm/ohm/fix_configure.patch39
-rw-r--r--meta/recipes-support/ohm/ohm_git.bb44
2 files changed, 83 insertions, 0 deletions
diff --git a/meta/recipes-support/ohm/ohm/fix_configure.patch b/meta/recipes-support/ohm/ohm/fix_configure.patch
new file mode 100644
index 0000000000..e4b774e785
--- /dev/null
+++ b/meta/recipes-support/ohm/ohm/fix_configure.patch
@@ -0,0 +1,39 @@
+Index: git/configure.in
+===================================================================
+--- git.orig/configure.in 2007-12-19 13:43:52.000000000 +0000
++++ git/configure.in 2008-03-06 23:59:57.000000000 +0000
+@@ -201,9 +201,6 @@
+ # Like AC_CHECK_HEADER, but it uses the already-computed -I directories.
+ AC_DEFUN(AC_CHECK_X_HEADER, [
+ ac_save_CPPFLAGS="$CPPFLAGS"
+- if test \! -z "$includedir" ; then
+- CPPFLAGS="$CPPFLAGS -I$includedir"
+- fi
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+ AC_CHECK_HEADER([$1],[$2],[$3],[$4])
+ CPPFLAGS="$ac_save_CPPFLAGS"])
+@@ -211,9 +208,6 @@
+ # Like AC_TRY_COMPILE, but it uses the already-computed -I directories.
+ AC_DEFUN(AC_TRY_X_COMPILE, [
+ ac_save_CPPFLAGS="$CPPFLAGS"
+- if test \! -z "$includedir" ; then
+- CPPFLAGS="$CPPFLAGS -I$includedir"
+- fi
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+ AC_TRY_COMPILE([$1], [$2], [$3], [$4])
+ CPPFLAGS="$ac_save_CPPFLAGS"])
+@@ -224,14 +218,8 @@
+ ac_save_CPPFLAGS="$CPPFLAGS"
+ ac_save_LDFLAGS="$LDFLAGS"
+ # ac_save_LIBS="$LIBS"
+- if test \! -z "$includedir" ; then
+- CPPFLAGS="$CPPFLAGS -I$includedir"
+- fi
+ # note: $X_CFLAGS includes $x_includes
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+- if test \! -z "$libdir" ; then
+- LDFLAGS="$LDFLAGS -L$libdir"
+- fi
+ # note: $X_LIBS includes $x_libraries
+ LDFLAGS="$LDFLAGS $ALL_X_LIBS"
+ AC_CHECK_LIB([$1], [$2], [$3], [$4], [$5])
diff --git a/meta/recipes-support/ohm/ohm_git.bb b/meta/recipes-support/ohm/ohm_git.bb
new file mode 100644
index 0000000000..2ba78b35ab
--- /dev/null
+++ b/meta/recipes-support/ohm/ohm_git.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Open Hardware Manager"
+HOMEPAGE = "http://freedesktop.org/Software/ohm"
+LICENSE = "LGPL"
+
+DEPENDS = "gtk+ dbus-glib intltool-native hal"
+RDEPENDS_${PN} += "udev hal-info"
+SRC_URI = "git://anongit.freedesktop.org/git/ohm/;protocol=git \
+ file://fix_configure.patch;patch=1"
+
+PV = "0.1.2+git-locrev${SRCREV}"
+PR = "r1"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--with-distro=debian \
+ --without-xauth \
+ --disable-gtk-doc \
+ --disable-docbook-docs"
+
+do_configure_prepend() {
+ touch gtk-doc.make
+}
+
+OE_LT_RPATH_ALLOW=":${libdir}/libohm:"
+OE_LT_RPATH_ALLOW[export]="1"
+
+PACKAGES =+ "libohm ohm-plugin-x11"
+
+FILES_${PN}-dev += "${libdir}/ohm/*.a"
+
+FILES_${PN} = "${sysconfdir} \
+ ${bindir}/* \
+ ${sbindir}/* \
+ ${libdir}/ohm/*.so \
+ "
+
+FILES_libohm = "${libdir}/libohm.so.*"
+FILES_ohm-plugin-x11 = "${libdir}/ohm/libohm_x*.so \
+ ${libdir}/ohm/libohm_idle.so \
+ ${sysconfdir}/ohm/plugins.d/x* \
+ ${sysconfdir}/ohm/plugins.d/idle* \
+ "