summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
new file mode 100644
index 0000000000..09fabdeebc
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "A C program to run all installed ptests"
+DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
+program which loops through all installed ptest test suites and \
+runs them in sequence."
+HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+
+SRCREV = "1e9a84585909b970cc8850d3ea02a7215dcfa5a3"
+PV = "2.4.0+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/ptest-runner2 \
+"
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} = "${bindir}/ptest-runner"
+
+EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
+}