summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-nose_1.3.7.bb
Commit message (Collapse)AuthorAgeFilesLines
* python-nose: python3-nose should be defaultRoss Burton2019-06-121-4/+0
| | | | | | | | | | We have nose recipes for both Py2 and Py3, but they both want to ship the unversioned nosetest binary. As Py2 is approaching EOL, remove the unversioned binary from python-nose (leaving nosetest-2.7) instead of renaming the binary to nosetest3 in python3-nose. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* python-nose: use pypi.bbclassTim Orling2017-12-131-23/+1
| | | | | | | | | * Simplify python- and python3-nose by using pypi.bbclass * Consolidate common content in python-nose.inc - Avoid duplication by using PYTHON_PN variable Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* python3-nose: rename ${bindir}/nosetests into ${bindir}/nosetests3Denys Dmytriyenko2017-05-181-0/+4
| | | | | | | | | | | | | | This resolves a conflict when both python-nose and python3-nose are pulled into an image and try to install ${bindir}/nosetests binary. This matches with how other distros are solving this problem, e.g. Debian: https://packages.debian.org/jessie/all/python3-nose/filelist Also, other packages like python3-setuptools are already doing the same with their binaries. Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* python: Several recipes needed SRC_URI updatingAlejandro Hernandez2016-06-121-1/+1
| | | | | | | | | | Most python recipes download its source from pypi.python.org, but they changed the way theyre storing the source code, so we need to use pythonhosted instead, see: https://bitbucket.org/pypa/pypi/issues/438/backwards-compatible-un-hashed-package Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
* python3-nose: add a recipeAlexander Kanavin2016-06-011-0/+24
This is needed for updating piglit to use Python 3. Python 2 based recipe can be later moved to meta-oe. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>