aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-07-07 20:45:28 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-07-07 20:45:28 +0200
commit9a0772ca64b0e14c53cbbb1865506a62b0edc81f (patch)
treeb73e1e2eab75e9c77c06554944b82068d88e55d0
parent49d09c8b3a483e37f3d7df934a7773fd9d21d409 (diff)
parentc59b050dc1130bf749772f00952c811cc236b7f7 (diff)
downloadopenembedded-9a0772ca64b0e14c53cbbb1865506a62b0edc81f.tar.gz
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
-rw-r--r--classes/base.bbclass15
-rw-r--r--recipes/rt2x00/rt2570-k2wrlz_1.6.4.bb29
2 files changed, 42 insertions, 2 deletions
diff --git a/classes/base.bbclass b/classes/base.bbclass
index 2da0b7a67d..b30310d446 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -219,14 +219,25 @@ def oe_unpack_file(file, data, url = None):
# The "destdir" handling was specifically done for FILESPATH
# items. So, only do so for file:// entries.
if type == "file":
- dest = os.path.dirname(path) or "."
+ if not host:
+ dest = os.path.dirname(path) or "."
+ else:
+ # this case is for backward compatiblity with older version
+ # of bitbake which do not have the fix
+ # http://cgit.openembedded.org/cgit.cgi/bitbake/commit/?id=ca257adc587bb0937ea76d8b32b654fdbf4192b8
+ # this should not be needed once all releases of bitbake has this fix
+ # applied/backported
+ dest = host + os.path.dirname(path) or "."
else:
dest = "."
bb.mkdirhier("%s" % os.path.join(os.getcwd(),dest))
cmd = 'cp %s %s' % (file, os.path.join(os.getcwd(), dest))
if not cmd:
return True
- dest = os.path.join(os.getcwd(), path)
+ if not host:
+ dest = os.path.join(os.getcwd(), path)
+ else:
+ dest = os.path.join(os.getcwd(), os.path.join(host, path))
if os.path.exists(dest):
if os.path.samefile(file, dest):
return True
diff --git a/recipes/rt2x00/rt2570-k2wrlz_1.6.4.bb b/recipes/rt2x00/rt2570-k2wrlz_1.6.4.bb
new file mode 100644
index 0000000000..12a034c990
--- /dev/null
+++ b/recipes/rt2x00/rt2570-k2wrlz_1.6.4.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Enhanced Driver for Ralink rt2570 USB 802.11g WiFi sticks"
+HOMEPAGE = "http://homepages.tu-darmstadt.de/~p_larbig/wlan"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+
+PR = "r0"
+
+SRC_URI = "http://homepages.tu-darmstadt.de/~p_larbig/wlan/${PN}-${PV}.tar.bz2"
+
+inherit module
+
+S = "${WORKDIR}/${PN}-${PV}/Module/"
+
+do_compile_prepend_arm () {
+ MAKE_TARGETS="arm"
+}
+
+do_compile() {
+ export KERNDIR=${STAGING_KERNEL_DIR}
+ module_do_compile
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+ install -m 0644 rt2570${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
+}
+
+SRC_URI[md5sum] = "21f6e873ad7ee34843dbcd1204f9eda3"
+SRC_URI[sha256sum] = "5b2d382504d0aee14cf24f0eb3c483a79c712f8aa1ca027a7d4425891f1bb2ec"