aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-03-26 18:03:50 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-03-27 00:38:01 +0100
commit40225fbb406dbeb07101c54b2a1da00b564a3262 (patch)
tree263e20ed8189b784d877d458403a12ab580e3425
parent12270185faaf8d4fad76badde50028ae77ab16e5 (diff)
downloadopenembedded-40225fbb406dbeb07101c54b2a1da00b564a3262.tar.gz
ekiga_git: fix configure not finding boost signals
Without that fix we have that in the configure log: checking whether the Boost::Signals library is available... yes checking for main in -lboost_signals-mt... no checking for main in -lboost_signals-boost_signals-mt... no But looking at config.log reveal something more problematic: configure:17760: checking for main in -lboost_signals-mt configure:17779: arm-angstrom-linux-gnueabi-g++ [...] -o conftest [...] -I/usr/include [...] -L/usr/lib conftest.cpp -lboost_signals-mt >&5 /usr/lib/libboost_signals-mt.so: file not recognized: File format not recognized Wich is fixed by this commit. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
-rw-r--r--recipes/ekiga/ekiga_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/ekiga/ekiga_git.bb b/recipes/ekiga/ekiga_git.bb
index 025767b2c6..1926b52cab 100644
--- a/recipes/ekiga/ekiga_git.bb
+++ b/recipes/ekiga/ekiga_git.bb
@@ -7,7 +7,7 @@ DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_angstrom = "1"
PV = "3.3.1+git"
-PR = "r6+gitr${SRCREV}"
+PR = "r7+gitr${SRCREV}"
SRCREV = "7c669dd4ce69296f09004f8876366058c20a3352"
inherit gnome
@@ -27,7 +27,8 @@ EXTRA_OECONF = " \
--enable-gstreamer \
--disable-gdu \
--disable-scrollkeeper \
- --with-boost-signals=boost_signals-mt \
+ --with-boost=${STAGING_DIR} \
+ --with-boost-signals=boost_signals \
"
do_configure_prepend() {