aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-03-16 11:28:17 -0700
committerTom Rini <tom_rini@mentor.com>2011-03-16 11:28:17 -0700
commit642719105bbce6fcb51acb10e402f26a6b247f95 (patch)
tree41dd0303bd61f2653a931736c9b158818e5108dd
parente35caa4763fab8f526c278437db7d8980a22d16d (diff)
downloadopenembedded-642719105bbce6fcb51acb10e402f26a6b247f95.tar.gz
ftpd-topfield: Rework usb-header-name-2-6-23.patch
While in here, clean up the recipe a bit. It's not autotools based and if we move the library in with an unpack2 the patch can be applied with striplevel=0. There are other problems with this recipe at present (CFLAGS/LDFLAGS in our env override the Makefile). Signed-off-by: Tom Rini <tom_rini@mentor.com>
-rw-r--r--recipes/ftpd-topfield/files/usb-header-name-2-6-23.patch4
-rwxr-xr-xrecipes/ftpd-topfield/ftpd-topfield_0.7.5.bb9
2 files changed, 8 insertions, 5 deletions
diff --git a/recipes/ftpd-topfield/files/usb-header-name-2-6-23.patch b/recipes/ftpd-topfield/files/usb-header-name-2-6-23.patch
index 2ab6c4c094..fd695d8508 100644
--- a/recipes/ftpd-topfield/files/usb-header-name-2-6-23.patch
+++ b/recipes/ftpd-topfield/files/usb-header-name-2-6-23.patch
@@ -1,5 +1,5 @@
---- ../../libtopfield/usb_io.h.orig 2008-12-26 23:11:08.000000000 -0600
-+++ ../../libtopfield/usb_io.h 2008-12-26 23:24:02.000000000 -0600
+--- libtopfield/usb_io.h.orig 2008-12-26 23:11:08.000000000 -0600
++++ libtopfield/usb_io.h 2008-12-26 23:24:02.000000000 -0600
@@ -36,7 +36,12 @@
/* linux/usb_ch9.h wasn't separated out until 2.4.23 */
diff --git a/recipes/ftpd-topfield/ftpd-topfield_0.7.5.bb b/recipes/ftpd-topfield/ftpd-topfield_0.7.5.bb
index 504f652393..b1dee21d5a 100755
--- a/recipes/ftpd-topfield/ftpd-topfield_0.7.5.bb
+++ b/recipes/ftpd-topfield/ftpd-topfield_0.7.5.bb
@@ -8,7 +8,7 @@ PR = "r3"
SRC_URI = "cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_7_5 \
cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_7_5 \
file://syslog.patch \
- file://usb-header-name-2-6-23.patch \
+ file://usb-header-name-2-6-23.patch;striplevel=0 \
file://init"
# The source will end up in the subdirectory 'ftpd-topfield' - no release name
@@ -19,9 +19,12 @@ inherit update-rc.d
INITSCRIPT_NAME = "ftpd-topfield"
INITSCRIPT_PARAMS = "defaults"
-# Just the one package at present
+do_unpack2() {
+ cd ${WORKDIR}
+ mv libtopfield ${S}/
+}
-inherit autotools
+addtask unpack2 after do_unpack before do_patch
do_compile() {
oe_runmake