aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwoglinde <heinold@inf.fu-berlin.de>2008-11-30 18:31:49 +0100
committerwoglinde <heinold@inf.fu-berlin.de>2008-11-30 18:33:08 +0100
commitf228ef8a476b56e561fd16d266dba4438c92613f (patch)
tree3b3c74f19511881fe20560c263143882eb9ab815
parentb7dea7728314fb969b3002bf2dd69e250ef61505 (diff)
downloadopenembedded-f228ef8a476b56e561fd16d266dba4438c92613f.tar.gz
qmake: add *linux-uclibcgnueabi-oe-g++ to the qmakespecs
* patch was provided by Andrea Adami <andrea.adami@gmail.com> alias ant * now we can build qt stuff with the arm-uclibc-eabi toolchain * bump PR on qmake-native and qmake2-native
-rw-r--r--classes/qmake_base.bbclass2
-rw-r--r--packages/qmake/qmake-native_1.07a.bb4
-rw-r--r--packages/qmake/qmake2-native.inc4
3 files changed, 5 insertions, 5 deletions
diff --git a/classes/qmake_base.bbclass b/classes/qmake_base.bbclass
index ea8903c278..5eccfa47e4 100644
--- a/classes/qmake_base.bbclass
+++ b/classes/qmake_base.bbclass
@@ -33,7 +33,7 @@ oe_qmake_mkspecs () {
qmake_base_do_configure() {
case ${QMAKESPEC} in
- *linux-oe-g++|*linux-uclibc-oe-g++|*linux-gnueabi-oe-g++)
+ *linux-oe-g++|*linux-uclibc-oe-g++|*linux-gnueabi-oe-g++|*linux-uclibcgnueabi-oe-g++)
;;
*-oe-g++)
die Unsupported target ${TARGET_OS} for oe-g++ qmake spec
diff --git a/packages/qmake/qmake-native_1.07a.bb b/packages/qmake/qmake-native_1.07a.bb
index 29f736dea1..a80bb1bb92 100644
--- a/packages/qmake/qmake-native_1.07a.bb
+++ b/packages/qmake/qmake-native_1.07a.bb
@@ -3,7 +3,7 @@ PRIORITY = "optional"
HOMEPAGE = "http://www.trolltech.com"
SECTION = "devel"
LICENSE = "GPL QPL"
-PR = "r4"
+PR = "r5"
QTEVER = "qt-embedded-free-3.3.5"
@@ -18,7 +18,7 @@ EXTRA_OEMAKE = "-e"
do_configure() {
# Install the OE build templates
- for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++
+ for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++ linux-uclibcgnueabi-oe-g++
do
install -d ${S}/mkspecs/$template
install -m 0644 ${WORKDIR}/linux-oe-qmake.conf ${S}/mkspecs/$template/qmake.conf
diff --git a/packages/qmake/qmake2-native.inc b/packages/qmake/qmake2-native.inc
index c9a0d400ff..467f130f2e 100644
--- a/packages/qmake/qmake2-native.inc
+++ b/packages/qmake/qmake2-native.inc
@@ -3,7 +3,7 @@ PRIORITY = "optional"
HOMEPAGE = "http://www.trolltech.com"
SECTION = "devel"
LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
# We call 'moc' during the build
DEPENDS = "uicmoc4-native"
@@ -29,7 +29,7 @@ do_configure() {
# Make sure we regenerate all Makefiles
find ${S} -name "Makefile" | xargs rm
# Install the OE build templates
- for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++
+ for template in linux-oe-g++ linux-uclibc-oe-g++ linux-gnueabi-oe-g++ linux-uclibcgnueabi-oe-g++
do
install -d ${S}/mkspecs/$template
install -m 0644 ${WORKDIR}/linux-oe-qmake.conf ${S}/mkspecs/$template/qmake.conf