aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-11-11 02:34:21 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-11-11 02:34:21 +0100
commitf5fbf1ff3ebbb35bdc6935decdd86f11ec415ff1 (patch)
tree07e7edd88ed5e4fb0b1a8acba55edfa3889d1bba
parent99f12bb3ac6f33d747e5def8644cba7ff01f382f (diff)
downloadopenembedded-f5fbf1ff3ebbb35bdc6935decdd86f11ec415ff1.tar.gz
libnl2: new recipe; netlink support library v2
-rw-r--r--conf/distro/include/sane-srcrevs.inc1
-rw-r--r--recipes/libnl/libnl2_git.bb23
2 files changed, 24 insertions, 0 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index b57ea4d673..ca88ae564d 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -89,6 +89,7 @@ SRCREV_pn-libmokogsmd2 ?= "4334"
SRCREV_pn-libmokojournal2 ?= "3473"
SRCREV_pn-libmokopanelui2 ?= "4568"
SRCREV_pn-libmokoui2 ?= "4342"
+SRCREV_pn-libnl2 ?= "dc273a12da9f0116e80fa81d63beb820e632dd17"
SRCREV_pn-libowl ?= "277"
SRCREV_pn-librfid ?= "2094"
SRCREV_pn-libsnmp-perl ?= "17367"
diff --git a/recipes/libnl/libnl2_git.bb b/recipes/libnl/libnl2_git.bb
new file mode 100644
index 0000000000..02010dc58d
--- /dev/null
+++ b/recipes/libnl/libnl2_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "libnl is a library for applications dealing with netlink sockets"
+SECTION = "libs/network"
+LICENSE = "LGPL"
+HOMEPAGE = "http://people.suug.ch/~tgr/libnl"
+PV = "1.0+gitr${SRCREV}"
+PR = "r0"
+
+inherit autotools pkgconfig
+
+#CFLAGS += '-DVLAN_FLAG_REORDER_HDR=1'
+
+SRC_URI = "git://git.kernel.org/pub/scm/libs/netlink/libnl.git;protocol=git"
+S = "${WORKDIR}/git"
+
+do_stage () {
+ autotools_stage_all prefix=${prefix}
+}
+
+PACKAGES =+ "${PN}-route ${PN}-nf ${PN}-genl"
+FILES_${PN}-route = "${libdir}/libnl-route.so.*"
+FILES_${PN}-nf = "${libdir}/libnl-nfd.so.*"
+FILES_${PN}-genl = "${libdir}/libnl-genl.so.*"
+