aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2008-11-04 22:10:10 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-11-04 22:10:10 +0100
commitc1401f7b1857e4dc00be14ce7d1aafd712ff5750 (patch)
tree868b4edb40f25d7053875f6f552734cfe74c0055
parent44a09d14b3b5637c4f4f7ee20d3504b52a1b949a (diff)
downloadopenembedded-c1401f7b1857e4dc00be14ce7d1aafd712ff5750.tar.gz
python-pygame: Blacklist smpeg and build pygame without smpeg
We can not build smpeg when enterprise is on. Put it into the BBMASK to make sure it is not buildable. Use base_conditional to not add the dependency to the DEPENDS when building for the enterprise branch. Remove the movie support (the one actually requiring smpeg) and only echo it into the Setup file when are not building with the ENTERPRISE_DISTRO flag. It seems to work both ways.
-rw-r--r--conf/enterprise.conf2
-rw-r--r--packages/python/python-pygame-1.8.1/Setup1
-rw-r--r--packages/python/python-pygame_1.8.1.bb8
3 files changed, 7 insertions, 4 deletions
diff --git a/conf/enterprise.conf b/conf/enterprise.conf
index 79637661dd..5f89cb1c5e 100644
--- a/conf/enterprise.conf
+++ b/conf/enterprise.conf
@@ -1,2 +1,2 @@
# For the enterprise edition we want to avoid certain packages by default.
-BBMASK = "${@base_conditional('ENTERPRISE_DISTRO', '1', '(gst-plugins-ugly|mp3blaster|mpg123|mpg321|liba52|lame|libmad|mpeg2dec|xmms-mad|madplay|libsidplay|sidplayer|python-mad|opie-mediaplayer1-libmadplugin)', '', d)}"
+BBMASK = "${@base_conditional('ENTERPRISE_DISTRO', '1', '(gst-plugins-ugly|mp3blaster|mpg123|mpg321|smpeg|liba52|lame|libmad|mpeg2dec|xmms-mad|madplay|libsidplay|sidplayer|python-mad|opie-mediaplayer1-libmadplugin)', '', d)}"
diff --git a/packages/python/python-pygame-1.8.1/Setup b/packages/python/python-pygame-1.8.1/Setup
index cb8085530a..932e291ae2 100644
--- a/packages/python/python-pygame-1.8.1/Setup
+++ b/packages/python/python-pygame-1.8.1/Setup
@@ -28,7 +28,6 @@ mixer src/mixer.c $(SDL) $(MIXER) $(DEBUG)
mixer_music src/music.c $(SDL) $(MIXER) $(DEBUG)
_numericsurfarray src/_numericsurfarray.c $(SDL) $(DEBUG)
_numericsndarray src/_numericsndarray.c $(SDL) $(MIXER) $(DEBUG)
-movie src/movie.c $(SDL) $(SMPEG) $(DEBUG)
scrap src/scrap.c $(SDL) $(SCRAP) $(DEBUG)
#experimental new movie movie. requires libavcodec and libavformat.
diff --git a/packages/python/python-pygame_1.8.1.bb b/packages/python/python-pygame_1.8.1.bb
index 71eff50dfb..499f0c6ee3 100644
--- a/packages/python/python-pygame_1.8.1.bb
+++ b/packages/python/python-pygame_1.8.1.bb
@@ -3,9 +3,10 @@ SECTION = "devel/python"
HOMEPAGE = "http://www.pygame.org"
PRIORITY = "optional"
LICENSE = "LGPL"
-DEPENDS = "libsdl-x11 libsdl-image libsdl-mixer libsdl-net libsdl-ttf smpeg python-numeric"
+DEPENDS = "libsdl-x11 libsdl-image libsdl-mixer libsdl-net libsdl-ttf python-numeric"
+DEPENDS += "${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'smpeg', d)}"
SRCNAME = "pygame"
-PR = "ml1"
+PR = "ml2"
SRC_URI = "\
ftp://ftp.pygame.org/pub/pygame/${SRCNAME}-${PV}release.tar.gz \
@@ -17,6 +18,9 @@ inherit distutils
do_configure_prepend() {
cat ${WORKDIR}/Setup >Setup
SDL="`sdl-config --cflags` `sdl-config --libs`"; echo "SDL=$SDL" >>Setup
+ if [ '${ENTERPRISE_DISTRO}' != '1' ]; then
+ echo "movie src/movie.c \$(SDL) \$(SMPEG) \$(DEBUG)" >>Setup
+ fi
}
do_stage() {