aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-01-04 15:37:05 +0800
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-01-07 11:21:47 +0100
commitd542c62b5af575ecfa6c4e353b1d57c27d3e12c3 (patch)
tree96938f14b025487f9940ffdcba19854a948b9787
parentd27fb2aec799ec77bb645541d7bd3fc9aa63529d (diff)
downloadopenembedded-d542c62b5af575ecfa6c4e353b1d57c27d3e12c3.tar.gz
qt4: Make the gles variants for Embedded and X11 provide the normal variant
This way a distribution/user can set PREFERRED_PROVIDER_qt4-embedded = "qt4-embedded-gles" to select the GLES/OpenVG runtime. The default is qt4-embedded as GLES require a dedicated library most of the time provided as a binary blob by the vendor requiring the user to manually download and store it at the right place. For X11 we already have a PREFERRED_PROVIDER setting in place and don't need to update. Acked-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--conf/compatibility-providers.conf1
-rw-r--r--recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled1
-rw-r--r--recipes/qt4/qt4-embedded-gles_4.6.0.bb1
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.5.2.bb1
-rw-r--r--recipes/qt4/qt4-x11-free-gles_4.6.0.bb1
-rw-r--r--recipes/qt4/qt4-x11-free-gles_git.bb.disabled1
6 files changed, 6 insertions, 0 deletions
diff --git a/conf/compatibility-providers.conf b/conf/compatibility-providers.conf
index 61a373003c..0d8e9bcaf7 100644
--- a/conf/compatibility-providers.conf
+++ b/conf/compatibility-providers.conf
@@ -47,6 +47,7 @@ PREFERRED_PROVIDER_openmoko-alsa-scenarios ?= "alsa-scenarii-shr"
PREFERRED_PROVIDER_opkg ?= "opkg"
#PREFERRED_PROVIDER_opkg ?= "opkg-nogpg"
PREFERRED_PROVIDER_qemu-native ?= "qemu-native"
+PREFERRED_PROVIDER_qt4-embedded ?= "qt4-embedded"
PREFERRED_PROVIDER_qt4-x11-free ?= "qt4-x11-free"
PREFERRED_PROVIDER_task-bootstrap ?= "task-bootstrap"
PREFERRED_PROVIDER_tslib-conf ?= "tslib"
diff --git a/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled b/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled
index 5aa07c2ebb..a888e7d6be 100644
--- a/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled
+++ b/recipes/qt4/qt4-embedded-gles_4.5.2.bb.disabled
@@ -9,6 +9,7 @@ require qt4-embedded_${PV}.bb
LICENSE = "LGPLv2.1 GPLv3"
DEPENDS += "virtual/egl"
+PROVIDES += "qt4-embedded"
SRC_URI += "file://sgx-hack.patch;patch=1"
export EXTRA_QMAKE_MUNGE = " glmunge "
diff --git a/recipes/qt4/qt4-embedded-gles_4.6.0.bb b/recipes/qt4/qt4-embedded-gles_4.6.0.bb
index 04e074f9dd..915dd0734f 100644
--- a/recipes/qt4/qt4-embedded-gles_4.6.0.bb
+++ b/recipes/qt4/qt4-embedded-gles_4.6.0.bb
@@ -1,6 +1,7 @@
require qt4-embedded.inc
PR = "${INC_PR}.1"
+PROVIDES += "qt4-embedded"
QT_GLFLAGS = "-opengl es2 -openvg"
require qt-4.6.0.inc
diff --git a/recipes/qt4/qt4-x11-free-gles_4.5.2.bb b/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
index cd81841269..a3f60bf982 100644
--- a/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
+++ b/recipes/qt4/qt4-x11-free-gles_4.5.2.bb
@@ -11,6 +11,7 @@ require qt4-x11-free_${PV}.bb
PR = "${INC_PR}.3"
DEPENDS += "virtual/egl"
+PROVIDES += "qt4-x11-free"
#SRC_URI += "file://sgx-hack.patch;patch=1"
SRC_URI += "file://hack-out-pg_config.patch;patch=1"
diff --git a/recipes/qt4/qt4-x11-free-gles_4.6.0.bb b/recipes/qt4/qt4-x11-free-gles_4.6.0.bb
index 089992c142..8d09d89f8d 100644
--- a/recipes/qt4/qt4-x11-free-gles_4.6.0.bb
+++ b/recipes/qt4/qt4-x11-free-gles_4.6.0.bb
@@ -13,5 +13,6 @@ QT_CONFIG_FLAGS += " \
FILESPATHPKG .= ":qt4-x11-free-${PV}:qt4-x11-free"
DEPENDS += "virtual/egl"
+PROVIDES += "qt4-x11-free"
diff --git a/recipes/qt4/qt4-x11-free-gles_git.bb.disabled b/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
index 22db2dfa8d..59778910b5 100644
--- a/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
+++ b/recipes/qt4/qt4-x11-free-gles_git.bb.disabled
@@ -5,6 +5,7 @@ FILESPATHPKG =. "qt4-x11-free-${PV}:qt4-x11-free:"
QT_GLFLAGS = "-opengl es1 -openvg"
require qt4-x11-free.inc
+PROVIDES = "qt4-x11-free"
LICENSE = "LGPLv2.1 GPLv3"
PR = "${INC_PR}.0+gitr${SRCREV}"