aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2006-11-22 11:29:49 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2006-11-22 11:29:49 +0000
commitdf56cecd68c1c2bcf772badbc19c2f78a8aec064 (patch)
tree728a8414369d78ab48449fbf406a4729c39f4cac
parent0a1b7ef98472f9ea083e987caa73e913718b3bd3 (diff)
downloadopenembedded-df56cecd68c1c2bcf772badbc19c2f78a8aec064.tar.gz
linux-nokia770: Add patches to fix compile.
-rw-r--r--packages/linux/linux-nokia770-2.6.16-osso26/fix_tlv320aic23_compile.patch11
-rw-r--r--packages/linux/linux-nokia770-2.6.16-osso26/fix_usb_hub_compile.patch19
-rw-r--r--packages/linux/linux-nokia770_2.6.16-osso26.bb4
3 files changed, 33 insertions, 1 deletions
diff --git a/packages/linux/linux-nokia770-2.6.16-osso26/fix_tlv320aic23_compile.patch b/packages/linux/linux-nokia770-2.6.16-osso26/fix_tlv320aic23_compile.patch
new file mode 100644
index 0000000000..66bf993878
--- /dev/null
+++ b/packages/linux/linux-nokia770-2.6.16-osso26/fix_tlv320aic23_compile.patch
@@ -0,0 +1,11 @@
+--- kernel-source-2.6.16-2.6.16.rel/drivers/i2c/chips/tlv320aic23.c.orig 2006-11-22 11:48:20.000000000 +0100
++++ kernel-source-2.6.16-2.6.16.rel/drivers/i2c/chips/tlv320aic23.c 2006-11-22 11:48:42.000000000 +0100
+@@ -184,7 +184,7 @@
+ }
+
+ static struct i2c_driver aic23_driver = {
+- .driver {
++ .driver = {
+ .name = "OMAP+TLV320AIC23 codec",
+ },
+ .id = I2C_DRIVERID_MISC,
diff --git a/packages/linux/linux-nokia770-2.6.16-osso26/fix_usb_hub_compile.patch b/packages/linux/linux-nokia770-2.6.16-osso26/fix_usb_hub_compile.patch
new file mode 100644
index 0000000000..a311fd0cb0
--- /dev/null
+++ b/packages/linux/linux-nokia770-2.6.16-osso26/fix_usb_hub_compile.patch
@@ -0,0 +1,19 @@
+--- kernel-source-2.6.16-2.6.16.rel/drivers/usb/core/hub.c.orig 2006-11-22 12:17:01.000000000 +0100
++++ kernel-source-2.6.16-2.6.16.rel/drivers/usb/core/hub.c 2006-11-22 12:17:48.000000000 +0100
+@@ -1289,6 +1289,7 @@
+ *
+ * Only the hub driver or root-hub registrar should ever call this.
+ */
++static int __usb_suspend_device(struct usb_device *, int port1);
+ int usb_new_device(struct usb_device *udev)
+ {
+ int err;
+@@ -1371,8 +1372,6 @@
+ * (Includes HNP test device.)
+ */
+ if (udev->bus->b_hnp_enable || udev->bus->is_b_host) {
+- static int __usb_suspend_device(struct usb_device *,
+- int port1);
+ err = __usb_suspend_device(udev, udev->bus->otg_port);
+ if (err < 0)
+ dev_dbg(&udev->dev, "HNP fail, %d\n", err);
diff --git a/packages/linux/linux-nokia770_2.6.16-osso26.bb b/packages/linux/linux-nokia770_2.6.16-osso26.bb
index ff239f9d06..3211f12927 100644
--- a/packages/linux/linux-nokia770_2.6.16-osso26.bb
+++ b/packages/linux/linux-nokia770_2.6.16-osso26.bb
@@ -1,9 +1,11 @@
SECTION = "kernel"
DESCRIPTION = "Linux kernel for Nokia 770"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://repository.maemo.org/pool/mistral/non-free/source/k/kernel-source-2.6.16/kernel-source-2.6.16_2.6.16.rel-osso15.tar.gz \
+ file://fix_tlv320aic23_compile.patch;patch=1 \
+ file://fix_usb_hub_compile.patch;patch=1 \
file://defconfig"
S = "${WORKDIR}/kernel-source-2.6.16-2.6.16.rel"