aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-09-02 11:51:51 +0200
committerKoen Kooi <koen@openembedded.org>2010-09-02 11:51:51 +0200
commite2249025ea431966312885573c2c999913ac8679 (patch)
tree2cf17ca01885c07c6465afca1c1b7f809e830c13
parent1d48a1c15d20e40e3479d7b09dc3ef1325a9f7ea (diff)
downloadopenembedded-e2249025ea431966312885573c2c999913ac8679.tar.gz
goffice: add 0.8.9
-rw-r--r--recipes/gnome/goffice_0.8.9.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/gnome/goffice_0.8.9.bb b/recipes/gnome/goffice_0.8.9.bb
new file mode 100644
index 0000000000..c4b6a244b9
--- /dev/null
+++ b/recipes/gnome/goffice_0.8.9.bb
@@ -0,0 +1,44 @@
+DESCRIPTION="Gnome Office Library"
+LICENSE="GPLv2"
+
+DEPENDS="glib-2.0 gtk+ pango cairo libgnomeprint libgsf libglade libpcre libxml2 libart-lgpl"
+
+inherit gnome pkgconfig
+
+SRC_URI += " file://c99math.patch \
+ file://nodolt.patch "
+
+SRC_URI[archive.md5sum] = "4fb1fc1a3757341fae69194e8b396d8e"
+SRC_URI[archive.sha256sum] = "d2bd0cde14f80ed538b9cf4960a019b46db27e2709379cf76da9747879f4a015"
+
+FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
+
+RRECOMMENDS_${PN} = " \
+ goffice-plugin-plot-barcol \
+ goffice-plugin-plot-distrib \
+ goffice-plugin-plot-pie \
+ goffice-plugin-plot-radar \
+ goffice-plugin-plot-surface \
+ goffice-plugin-plot-xy \
+ goffice-plugin-reg-linear \
+ goffice-plugin-reg-logfit \
+ goffice-plugin-smoothing \
+"
+
+FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
+ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+ ${base_bindir}/* ${base_sbindir}/* \
+ ${base_libdir}/*${SOLIBS} \
+ ${datadir}/${PN} \
+ ${datadir}/pixmaps ${datadir}/applications \
+ ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
+ ${libdir}/bonobo/servers"
+
+PACKAGES_DYNAMIC = "goffice-plugin-*"
+
+python populate_packages_prepend () {
+ goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d)
+
+ do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
+}
+