aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2009-07-21 15:15:05 +0200
committerFlorian Boor <florian.boor@kernelconcepts.de>2009-07-21 15:21:10 +0200
commit1751ba9cc1377eaa2d2de8b2053abea807731d80 (patch)
tree8344bbc52aa87b4eba8fe0e2d5939864d31312b1
parentf2bd580f9b70a5df142c2424b004a87c2646793a (diff)
downloadopenembedded-1751ba9cc1377eaa2d2de8b2053abea807731d80.tar.gz
tslib: Include patch to make it work with all drivers that don't supply pressure information.
-rw-r--r--recipes/tslib/tslib/tslib-nopressure.patch30
-rw-r--r--recipes/tslib/tslib_1.0.bb5
2 files changed, 33 insertions, 2 deletions
diff --git a/recipes/tslib/tslib/tslib-nopressure.patch b/recipes/tslib/tslib/tslib-nopressure.patch
new file mode 100644
index 0000000000..1b19b43c52
--- /dev/null
+++ b/recipes/tslib/tslib/tslib-nopressure.patch
@@ -0,0 +1,30 @@
+diff -ur tslib-1.0/plugins/input-raw.c tslib/plugins/input-raw.c
+--- tslib-1.0/plugins/input-raw.c 2006-08-24 23:02:54.000000000 +0200
++++ tslib/plugins/input-raw.c 2009-07-21 00:54:29.000000000 +0200
+@@ -95,7 +95,11 @@
+ case EV_KEY:
+ switch (ev.code) {
+ case BTN_TOUCH:
+- if (ev.value == 0) {
++ if (ev.value) {
++ samp->x = i->current_x;
++ samp->y = i->current_y;
++ samp->pressure = i->current_p = 1;
++ } else {
+ /* pen up */
+ samp->x = 0;
+ samp->y = 0;
+@@ -198,7 +202,11 @@
+ } else if (ev.type == EV_KEY) {
+ switch (ev.code) {
+ case BTN_TOUCH:
+- if (ev.value == 0) {
++ if (ev.value) {
++ samp->x = i->current_x;
++ samp->y = i->current_y;
++ samp->pressure = i->current_p = 1;
++ } else {
+ /* pen up */
+ samp->x = 0;
+ samp->y = 0;
+
diff --git a/recipes/tslib/tslib_1.0.bb b/recipes/tslib/tslib_1.0.bb
index c22256f4d2..1929ee0557 100644
--- a/recipes/tslib/tslib_1.0.bb
+++ b/recipes/tslib/tslib_1.0.bb
@@ -1,5 +1,6 @@
SRC_URI = "http://download.berlios.de/tslib/${BP}.tar.bz2 \
- file://fix_version.patch;patch=1"
-PR = "${INC_PR}.1"
+ file://fix_version.patch;patch=1 \
+ file://tslib-nopressure.patch;patch=1"
+PR = "${INC_PR}.2"
include tslib.inc