aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-12-12 23:20:24 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-12-13 21:46:28 +0100
commit2b1ee3146f8ca602074c2860b135071ae1de440d (patch)
tree4edb9f32878cb68cdf4e89cd20b7ab794086ac0f
parent99a553d1ebd546513cee6f92b489f5ea3049a725 (diff)
downloadopenembedded-2b1ee3146f8ca602074c2860b135071ae1de440d.tar.gz
fmtools: fix QA staging(GNU hash)
Without that fix we have: ERROR: QA Issue with fmtools: No GNU_HASH in the elf binary: '.../work/armv7a-oe-linux-gnueabi/fmtools-1.0.2-r1/packages-split/fmtools/usr/bin/fm' ERROR: QA Issue with fmtools: No GNU_HASH in the elf binary: '.../work/armv7a-oe-linux-gnueabi/fmtools-1.0.2-r1/packages-split/fmtools/usr/bin/fmscan' ERROR: QA run found fatal errors. Please consider fixing them. Note that fmtools Makefile has no way to pass the LDFLAGS to it Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
-rw-r--r--recipes/fmtools/fmtools_1.0.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/recipes/fmtools/fmtools_1.0.2.bb b/recipes/fmtools/fmtools_1.0.2.bb
index 2d060cc46c..8dbef8c9fb 100644
--- a/recipes/fmtools/fmtools_1.0.2.bb
+++ b/recipes/fmtools/fmtools_1.0.2.bb
@@ -1,12 +1,14 @@
DESCRIPTION = "fmtools - programs for Video for Linux radio cards"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.stanford.edu/~blp/fmtools/fmtools-1.0.2.tar.gz \
file://makefile.patch"
inherit autotools
+CFLAGS += "${LDFLAGS}"
+
do_install() {
install -d ${D}${bindir}
install -m 0755 ${S}/fm ${D}${bindir}/fm