aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-12-10 12:22:28 +0100
committerKoen Kooi <koen@openembedded.org>2009-12-10 17:56:26 +0100
commit2f6358fffd24715cf4f927874a7b13ef2a58f390 (patch)
tree888b8eeeef7bf2edc8db5e3607748db664e92c4c
parente3c3b66a4ea5ec0910f3c8a1c3052ce418f6d352 (diff)
downloadopenembedded-2f6358fffd24715cf4f927874a7b13ef2a58f390.tar.gz
qt 4.6.0: move common 4.6 stuff to a .inc
-rw-r--r--recipes/qt4/qt-4.6.0.inc38
-rw-r--r--recipes/qt4/qt4-embedded_4.6.0.bb35
-rw-r--r--recipes/qt4/qt4-x11-free_4.6.0.bb37
3 files changed, 40 insertions, 70 deletions
diff --git a/recipes/qt4/qt-4.6.0.inc b/recipes/qt4/qt-4.6.0.inc
new file mode 100644
index 0000000000..aa85facce7
--- /dev/null
+++ b/recipes/qt4/qt-4.6.0.inc
@@ -0,0 +1,38 @@
+DEFAULT_PREFERENCE = "-1"
+
+require qt4-embedded.inc
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
+ file://0001-cross-compile.patch;patch=1 \
+ file://0002-fix-resinit-declaration.patch;patch=1 \
+ file://0004-no-qmake.patch;patch=1 \
+ file://0006-freetype-host-includes.patch;patch=1 \
+ file://0008-qt-lib-infix.patch;patch=1 \
+ file://0009-support-2bpp.patch;patch=1 \
+ file://fix-config-tests.patch;patch=1 \
+ file://g++.conf \
+ file://linux.conf \
+ "
+S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
+
+do_configure_prepend() {
+ sed -i \
+ -e /QMAKE_MOC\ /d \
+ -e /QMAKE_UIC\ /d \
+ -e /QMAKE_UIC3\ /d \
+ -e /QMAKE_RCC\ /d \
+ ${S}/configure
+
+# sed -i /tools.pro/d ${S}/src/src.pro
+}
+
+do_install_append() {
+ install -d ${D}${bindir}
+ for i in rcc uic moc ; do
+ install -m 0755 ${S}/bin/$i ${D}${bindir}/
+ done
+}
+
+LICENSE = "LGPLv2.1 GPLv3"
+SRC_URI += " \
+ file://hack-out-pg_config.patch;patch=1"
diff --git a/recipes/qt4/qt4-embedded_4.6.0.bb b/recipes/qt4/qt4-embedded_4.6.0.bb
index 1bdca87a0d..3bde65014d 100644
--- a/recipes/qt4/qt4-embedded_4.6.0.bb
+++ b/recipes/qt4/qt4-embedded_4.6.0.bb
@@ -1,38 +1,5 @@
-DEFAULT_PREFERENCE = "-1"
-
-require qt4-embedded.inc
PR = "${INC_PR}.0"
-SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
- file://0001-cross-compile.patch;patch=1 \
- file://0002-fix-resinit-declaration.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://0006-freetype-host-includes.patch;patch=1 \
- file://0008-qt-lib-infix.patch;patch=1 \
- file://0009-support-2bpp.patch;patch=1 \
- file://fix-config-tests.patch;patch=1 \
- file://g++.conf \
- file://linux.conf \
- "
-S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
-
-do_configure_prepend() {
- sed -i \
- -e /QMAKE_MOC\ /d \
- -e /QMAKE_UIC\ /d \
- -e /QMAKE_UIC3\ /d \
- -e /QMAKE_RCC\ /d \
- ${S}/configure
-}
-
-do_install_append() {
- install -d ${D}${bindir}
- for i in rcc uic moc ; do
- install -m 0755 ${S}/bin/$i ${D}${bindir}/
- done
-}
+require qt-4.6.0.inc
-LICENSE = "LGPLv2.1 GPLv3"
-SRC_URI += " \
- file://hack-out-pg_config.patch;patch=1"
diff --git a/recipes/qt4/qt4-x11-free_4.6.0.bb b/recipes/qt4/qt4-x11-free_4.6.0.bb
index 4b5eabff5c..1b5b4524c8 100644
--- a/recipes/qt4/qt4-x11-free_4.6.0.bb
+++ b/recipes/qt4/qt4-x11-free_4.6.0.bb
@@ -1,45 +1,10 @@
-DEFAULT_PREFERENCE = "-1"
-
-require qt4-x11-free.inc
-LICENSE = "LGPLv2.1 GPLv3"
PR = "${INC_PR}.0"
-export MOC = "${OE_QMAKE_MOC}"
-export QMAKE_MOC = "${OE_QMAKE_MOC}"
-
-SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-everywhere-opensource-src-${PV}.tar.gz \
- file://0001-cross-compile.patch;patch=1 \
- file://0002-fix-resinit-declaration.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://0006-freetype-host-includes.patch;patch=1 \
- file://0008-qt-lib-infix.patch;patch=1 \
- file://fix-config-tests.patch;patch=1 \
- file://g++.conf \
- file://linux.conf \
-"
-
-SRC_URI += "file://hack-out-pg_config.patch;patch=1"
-
-S = "${WORKDIR}/qt-everywhere-opensource-src-${PV}"
+require qt-4.6.0.inc
QT_CONFIG_FLAGS += " \
-no-embedded \
-xrandr \
-x11"
-do_configure_prepend() {
- sed -i \
- -e /QMAKE_MOC\ /d \
- -e /QMAKE_UIC\ /d \
- -e /QMAKE_UIC3\ /d \
- -e /QMAKE_RCC\ /d \
- ${S}/configure
-}
-
-do_install_append() {
- install -d ${D}${bindir}
- for i in rcc uic moc ; do
- install -m 0755 ${S}/bin/$i ${D}${bindir}/
- done
-}