aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-03-16 10:54:50 -0700
committerSteffen Sledz <sledz@dresearch-fe.de>2011-04-29 14:08:37 +0200
commit5c0d4ffb7d368b5cdce251728b6db690cbab822a (patch)
tree0231d407a1a54120d1bf25984fa3607dd2cef3b5
parent5101597a82fa1cbf4d6686ed4aa683474ac4b3c7 (diff)
downloadopenembedded-5c0d4ffb7d368b5cdce251728b6db690cbab822a.tar.gz
db: Rework arm-thumb-mutex_db5.patch
Signed-off-by: Tom Rini <tom_rini@mentor.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes/db/db-5.1.19/arm-thumb-mutex_db5.patch4
-rw-r--r--recipes/db/db_5.1.19.bb6
2 files changed, 6 insertions, 4 deletions
diff --git a/recipes/db/db-5.1.19/arm-thumb-mutex_db5.patch b/recipes/db/db-5.1.19/arm-thumb-mutex_db5.patch
index 37d0d93abd..51d485499e 100644
--- a/recipes/db/db-5.1.19/arm-thumb-mutex_db5.patch
+++ b/recipes/db/db-5.1.19/arm-thumb-mutex_db5.patch
@@ -1,5 +1,5 @@
---- db-5.1.19/../src/dbinc/mutex_int.h.orig 2011-01-05 19:21:42.181805366 -0600
-+++ db-5.1.19/../src/dbinc/mutex_int.h 2011-01-05 19:24:53.141853117 -0600
+--- db-5.1.19/src/dbinc/mutex_int.h.orig 2011-01-05 19:21:42.181805366 -0600
++++ db-5.1.19/src/dbinc/mutex_int.h 2011-01-05 19:24:53.141853117 -0600
@@ -474,6 +474,25 @@
#ifdef LOAD_ACTUAL_MUTEX_CODE
diff --git a/recipes/db/db_5.1.19.bb b/recipes/db/db_5.1.19.bb
index c44b958f75..9c25876706 100644
--- a/recipes/db/db_5.1.19.bb
+++ b/recipes/db/db_5.1.19.bb
@@ -14,10 +14,10 @@ HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
LICENSE = "BSD Sleepycat"
VIRTUAL_NAME ?= "virtual/db"
CONFLICTS = "db3"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
-SRC_URI += "file://arm-thumb-mutex_db5.patch"
+SRC_URI += "file://arm-thumb-mutex_db5.patch;apply=false"
SRC_URI[md5sum] = "76fcbfeebfcd09ba0b4d96bfdf8d884d"
SRC_URI[sha256sum] = "0194d4ca9266ba1a1c0bfbc233b18bfd05f63163453c81ebcdfdc7112d5ac850"
@@ -74,6 +74,8 @@ EXTRA_OECONF += "${MUTEX}"
# configure.
CONFIG_SITE = ""
do_configure() {
+ # Apply this patch in the correct spot
+ (cd .. ; patch -p1 -i ${WORKDIR}/arm-thumb-mutex_db5.patch)
oe_runconf
}