aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-01-20 17:33:32 +0000
committerTom Rini <tom_rini@mentor.com>2011-02-09 09:22:42 -0700
commit71a1e1a6e6b89d4ced9c9ab537614e1e521389b0 (patch)
treee12499aa355819d555d2e71353cd3e364290cb01
parent0978356c5b31861505240fd81e4fa2236682b8eb (diff)
downloadopenembedded-71a1e1a6e6b89d4ced9c9ab537614e1e521389b0.tar.gz
libnewt: include latest fixes and allow python removal
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes/newt/files/include-without-python.patch71
-rw-r--r--recipes/newt/files/support-DESTDIR.patch12
-rw-r--r--recipes/newt/libnewt_0.52.12.bb18
3 files changed, 83 insertions, 18 deletions
diff --git a/recipes/newt/files/include-without-python.patch b/recipes/newt/files/include-without-python.patch
new file mode 100644
index 0000000000..277ee3324d
--- /dev/null
+++ b/recipes/newt/files/include-without-python.patch
@@ -0,0 +1,71 @@
+From 3d13bbbb769050fac4cc6c904c174edc27e4f03d Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Thu, 20 Jan 2011 14:14:51 -0200
+Subject: [PATCH] build: add -without-python
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ Makefile.in | 8 ++++----
+ configure.ac | 10 ++++++++--
+ 2 files changed, 12 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index e764e61..74e9097 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -77,7 +77,7 @@ showkey: showkey.o $(LIBNEWT)
+ $(CC) -g -o showkey showkey.o $(LIBNEWT) $(LDFLAGS) $(LIBS)
+
+ _snackmodule.so: snackmodule.c $(LIBNEWTSH)
+- for ver in $(PYTHONVERS) ; do \
++ [ -n "$(PYTHONVERS)" ] && for ver in $(PYTHONVERS) ; do \
+ mkdir -p $$ver ;\
+ PCFLAGS=`$$ver-config --cflags`; \
+ PIFLAGS=`$$ver-config --includes`; \
+@@ -85,7 +85,7 @@ _snackmodule.so: snackmodule.c $(LIBNEWTSH)
+ PLFLAGS=`$$ver-config --libs`; \
+ $(CC) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c ;\
+ $(CC) --shared $$PLDFLAGS $$PLFLAGS $(LDFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L. -lnewt $(LIBS);\
+- done
++ done || :
+ touch $@
+
+ whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
+@@ -141,11 +141,11 @@ install-sh: sharedlib $(WHIPTCLSO) _snackmodule.so
+ ln -sf $(LIBNEWTSONAME) $(instroot)/$(libdir)/libnewt.so
+ ln -sf $(LIBNEWTSH) $(instroot)/$(libdir)/$(LIBNEWTSONAME)
+ [ -n "$(WHIPTCLSO)" ] && install -m 755 whiptcl.so $(instroot)/$(libdir) || :
+- for ver in $(PYTHONVERS) ; do \
++ [ -n "$(PYTHONVERS)" ] && for ver in $(PYTHONVERS) ; do \
+ [ -d $(instroot)/$(libdir)/$$ver/site-packages ] || install -m 755 -d $(instroot)/$(libdir)/$$ver/site-packages ;\
+ install -m 755 $$ver/_snackmodule.so $(instroot)/$(libdir)/$$ver/site-packages ;\
+ install -m 644 snack.py $(instroot)/$(libdir)/$$ver/site-packages ;\
+- done
++ done || :
+
+ Makefile: newt.spec
+ echo "You need to rerun ./configure before continuing"
+diff --git a/configure.ac b/configure.ac
+index 7bc381a..dc04352 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -54,8 +54,14 @@ fi
+ AC_CHECK_HEADERS([popt.h libintl.h])
+
+ AC_MSG_CHECKING([for python versions])
+-PYTHONVERS=$(echo /usr/include/python*/Python.h | sed "s|/usr/include/||g"| sed "s|/Python.h||g" 2> /dev/null)
+-AC_MSG_RESULT([$PYTHONVERS])
++AC_ARG_WITH([python], [ --without-python do not compile python support])
++if test "x$with_python" = "xno"; then
++ AC_MSG_RESULT([skipped])
++ PYTHONVERS=
++else
++ PYTHONVERS=$(ls /usr/include/python*/Python.h 2> /dev/null | sed "s|/usr/include/||g"| sed "s|/Python.h||g" 2> /dev/null)
++ AC_MSG_RESULT([$PYTHONVERS])
++fi
+ AC_SUBST([PYTHONVERS])
+
+ AC_ARG_WITH([tcl], [ --without-tcl do not compile whiptcl.so])
+--
+1.7.2.3
+
diff --git a/recipes/newt/files/support-DESTDIR.patch b/recipes/newt/files/support-DESTDIR.patch
deleted file mode 100644
index cfc8904044..0000000000
--- a/recipes/newt/files/support-DESTDIR.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/Makefile.in b/Makefile.in
-index f64ffe3..fb13749 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -36,6 +36,7 @@ datadir = @datadir@
- mandir = @mandir@
- man1dir = $(mandir)/man1
- pkgconfigdir = $(libdir)/pkgconfig
-+instroot ?= $(DESTDIR)
-
- #--------------------------------------
-
diff --git a/recipes/newt/libnewt_0.52.12.bb b/recipes/newt/libnewt_0.52.12.bb
index f5de9c24c2..606101ebdd 100644
--- a/recipes/newt/libnewt_0.52.12.bb
+++ b/recipes/newt/libnewt_0.52.12.bb
@@ -6,15 +6,21 @@ LICENSE = "LGPL"
# slang needs to be >= 2.2
DEPENDS = "slang popt"
-SRC_URI = "http://fedorahosted.org/releases/n/e/newt/newt-${PV}.tar.gz \
- file://support-DESTDIR.patch"
-S = "${WORKDIR}/newt-${PV}"
+PR = "r1"
+
+SRCREV = "c3c7be75f6ef1adfc2be5f99c1e8ef3f0ab58c38"
+SRC_URI = "git://git.fedorahosted.org/git/newt;protocol=git \
+ file://include-without-python.patch"
+S = "${WORKDIR}/git"
+
+EXTRA_OECONF = "--without-python --without-tcl"
inherit autotools
PACKAGES_prepend = "whiptail "
-FILES_whiptail = "${bindir}/whiptail"
+do_configure_prepend() {
+ sh autogen.sh
+}
-SRC_URI[md5sum] = "51b04128d9e1bf000fa769c417b74486"
-SRC_URI[sha256sum] = "2ba88dc3d118daf509c58e3707c43ad57dd3415d8164054e93fe76439f348529"
+FILES_whiptail = "${bindir}/whiptail"