aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-11-15 12:14:22 -0800
committerKhem Raj <raj.khem@gmail.com>2010-11-15 12:14:22 -0800
commit7b4734daf2b59d0255c5e8f28aeb27740bd034c1 (patch)
tree751f1a32792e6482d2655c8b7dafbadb440454df
parentd9997db446c3e3f135e6f14794cea118d0b160a4 (diff)
downloadopenembedded-7b4734daf2b59d0255c5e8f28aeb27740bd034c1.tar.gz
binutils: Use git instead of cvs for SRC_URI for upstream version of binutils
* Use the upcoming 2.21 branch as SRC_URI so that we can test it and provide feedback to upstream based on our testing use PREFERRED_VERSION_binutils-cross = "git" to select this and test it in builds and reports issues. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/binutils/binutils-cross-sdk_cvs.bb36
-rw-r--r--recipes/binutils/binutils-cross-sdk_git.bb2
-rw-r--r--recipes/binutils/binutils-cross_cvs.bb7
-rw-r--r--recipes/binutils/binutils-cross_git.bb3
-rw-r--r--recipes/binutils/binutils-git/110-arm-eabi-conf.patch (renamed from recipes/binutils/binutils-cvs/110-arm-eabi-conf.patch)0
-rw-r--r--recipes/binutils/binutils-git/binutils-2.16.1-e300c2c3.patch (renamed from recipes/binutils/binutils-cvs/binutils-2.16.1-e300c2c3.patch)0
-rw-r--r--recipes/binutils/binutils-git/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch (renamed from recipes/binutils/binutils-cvs/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch)0
-rw-r--r--recipes/binutils/binutils-git/binutils-arm-pr7093.patch (renamed from recipes/binutils/binutils-cvs/binutils-arm-pr7093.patch)0
-rw-r--r--recipes/binutils/binutils-git/binutils-uclibc-100-uclibc-conf.patch (renamed from recipes/binutils/binutils-cvs/binutils-uclibc-100-uclibc-conf.patch)0
-rw-r--r--recipes/binutils/binutils-git/binutils-uclibc-300-001_ld_makefile_patch.patch (renamed from recipes/binutils/binutils-cvs/binutils-uclibc-300-001_ld_makefile_patch.patch)0
-rw-r--r--recipes/binutils/binutils-git/binutils-uclibc-300-006_better_file_error.patch (renamed from recipes/binutils/binutils-cvs/binutils-uclibc-300-006_better_file_error.patch)0
-rw-r--r--recipes/binutils/binutils-git/binutils-uclibc-300-012_check_ldrunpath_length.patch (renamed from recipes/binutils/binutils-cvs/binutils-uclibc-300-012_check_ldrunpath_length.patch)0
-rw-r--r--recipes/binutils/binutils-git/binutils-uclibc-gas-needs-libm.patch (renamed from recipes/binutils/binutils-cvs/binutils-uclibc-gas-needs-libm.patch)0
-rw-r--r--recipes/binutils/binutils_cvs.bb51
-rw-r--r--recipes/binutils/binutils_git.bb15
15 files changed, 20 insertions, 94 deletions
diff --git a/recipes/binutils/binutils-cross-sdk_cvs.bb b/recipes/binutils/binutils-cross-sdk_cvs.bb
deleted file mode 100644
index 985ed1a2a2..0000000000
--- a/recipes/binutils/binutils-cross-sdk_cvs.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-require binutils_cvs.bb
-require binutils-cross-sdk.inc
-
-PV = "2.20+cvs${SRCDATE}"
-
-PR = "${INC_PR}.2"
-FILESPATHPKG .= ":binutils-cvs"
-
-do_install () {
- oe_runmake 'DESTDIR=${D}' install-ld install-binutils install-gas
-
- # We don't really need these, so we'll remove them...
- rm -rf ${D}${libdir}/ldscripts
-
- # Fix the /usr/${TARGET_SYS}/bin/* links
- for l in ${D}${prefix}/${TARGET_SYS}/bin/*; do
- rm -f $l
- ln -sf `echo ${prefix}/${TARGET_SYS}/bin \
- | tr -s / \
- | sed -e 's,^/,,' -e 's,[^/]*,..,g'`${bindir}/${TARGET_PREFIX}`basename $l` $l
- done
-
- # Install the libiberty header
- install -d ${D}${includedir}
- install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
- install -m 644 ${S}/include/libiberty.h ${D}${includedir}
-
- cd ${D}${bindir}
-
- # Symlinks for ease of running these on the native target
- for p in ${TARGET_SYS}-* ; do
- ln -sf $p `echo $p | sed -e s,${TARGET_SYS}-,,`
- done
-
- rm ${D}${bindir}/ar ${D}${bindir}/strings
-}
diff --git a/recipes/binutils/binutils-cross-sdk_git.bb b/recipes/binutils/binutils-cross-sdk_git.bb
new file mode 100644
index 0000000000..876af0b0f1
--- /dev/null
+++ b/recipes/binutils/binutils-cross-sdk_git.bb
@@ -0,0 +1,2 @@
+require binutils_git.bb
+require binutils-cross-sdk.inc
diff --git a/recipes/binutils/binutils-cross_cvs.bb b/recipes/binutils/binutils-cross_cvs.bb
deleted file mode 100644
index eee356d3f0..0000000000
--- a/recipes/binutils/binutils-cross_cvs.bb
+++ /dev/null
@@ -1,7 +0,0 @@
-require binutils_cvs.bb
-require binutils-cross.inc
-FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/binutils-cvs"
-
-do_install () {
- oe_runmake install-ld install-binutils install-gas
-}
diff --git a/recipes/binutils/binutils-cross_git.bb b/recipes/binutils/binutils-cross_git.bb
new file mode 100644
index 0000000000..2df31fd663
--- /dev/null
+++ b/recipes/binutils/binutils-cross_git.bb
@@ -0,0 +1,3 @@
+require binutils_git.bb
+require binutils-cross.inc
+FILESPATHPKG =. "binutils-git:"
diff --git a/recipes/binutils/binutils-cvs/110-arm-eabi-conf.patch b/recipes/binutils/binutils-git/110-arm-eabi-conf.patch
index 2623301da0..2623301da0 100644
--- a/recipes/binutils/binutils-cvs/110-arm-eabi-conf.patch
+++ b/recipes/binutils/binutils-git/110-arm-eabi-conf.patch
diff --git a/recipes/binutils/binutils-cvs/binutils-2.16.1-e300c2c3.patch b/recipes/binutils/binutils-git/binutils-2.16.1-e300c2c3.patch
index c5e4234f22..c5e4234f22 100644
--- a/recipes/binutils/binutils-cvs/binutils-2.16.1-e300c2c3.patch
+++ b/recipes/binutils/binutils-git/binutils-2.16.1-e300c2c3.patch
diff --git a/recipes/binutils/binutils-cvs/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch b/recipes/binutils/binutils-git/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch
index 8df5b1fea0..8df5b1fea0 100644
--- a/recipes/binutils/binutils-cvs/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch
+++ b/recipes/binutils/binutils-git/binutils-2.16.91.0.6-objcopy-rename-errorcode.patch
diff --git a/recipes/binutils/binutils-cvs/binutils-arm-pr7093.patch b/recipes/binutils/binutils-git/binutils-arm-pr7093.patch
index ad4a556e0f..ad4a556e0f 100644
--- a/recipes/binutils/binutils-cvs/binutils-arm-pr7093.patch
+++ b/recipes/binutils/binutils-git/binutils-arm-pr7093.patch
diff --git a/recipes/binutils/binutils-cvs/binutils-uclibc-100-uclibc-conf.patch b/recipes/binutils/binutils-git/binutils-uclibc-100-uclibc-conf.patch
index 8de04e0fe0..8de04e0fe0 100644
--- a/recipes/binutils/binutils-cvs/binutils-uclibc-100-uclibc-conf.patch
+++ b/recipes/binutils/binutils-git/binutils-uclibc-100-uclibc-conf.patch
diff --git a/recipes/binutils/binutils-cvs/binutils-uclibc-300-001_ld_makefile_patch.patch b/recipes/binutils/binutils-git/binutils-uclibc-300-001_ld_makefile_patch.patch
index 04a7e61e25..04a7e61e25 100644
--- a/recipes/binutils/binutils-cvs/binutils-uclibc-300-001_ld_makefile_patch.patch
+++ b/recipes/binutils/binutils-git/binutils-uclibc-300-001_ld_makefile_patch.patch
diff --git a/recipes/binutils/binutils-cvs/binutils-uclibc-300-006_better_file_error.patch b/recipes/binutils/binutils-git/binutils-uclibc-300-006_better_file_error.patch
index f337611edf..f337611edf 100644
--- a/recipes/binutils/binutils-cvs/binutils-uclibc-300-006_better_file_error.patch
+++ b/recipes/binutils/binutils-git/binutils-uclibc-300-006_better_file_error.patch
diff --git a/recipes/binutils/binutils-cvs/binutils-uclibc-300-012_check_ldrunpath_length.patch b/recipes/binutils/binutils-git/binutils-uclibc-300-012_check_ldrunpath_length.patch
index b6f5a25ceb..b6f5a25ceb 100644
--- a/recipes/binutils/binutils-cvs/binutils-uclibc-300-012_check_ldrunpath_length.patch
+++ b/recipes/binutils/binutils-git/binutils-uclibc-300-012_check_ldrunpath_length.patch
diff --git a/recipes/binutils/binutils-cvs/binutils-uclibc-gas-needs-libm.patch b/recipes/binutils/binutils-git/binutils-uclibc-gas-needs-libm.patch
index db838cf20c..db838cf20c 100644
--- a/recipes/binutils/binutils-cvs/binutils-uclibc-gas-needs-libm.patch
+++ b/recipes/binutils/binutils-git/binutils-uclibc-gas-needs-libm.patch
diff --git a/recipes/binutils/binutils_cvs.bb b/recipes/binutils/binutils_cvs.bb
deleted file mode 100644
index 239ef7a6ea..0000000000
--- a/recipes/binutils/binutils_cvs.bb
+++ /dev/null
@@ -1,51 +0,0 @@
-FILESPATHPKG =. "binutils-cvs:"
-SRCDATE = "20100913"
-PV = "2.20+cvs${SRCDATE}"
-
-require binutils.inc
-PR = "${INC_PR}.2"
-
-S = "${WORKDIR}/src"
-EXTRA_OEMAKE = "configure-build-libiberty"
-SRC_URI = "cvs://anoncvs:anoncvs@sources.redhat.com/cvs/src;module=binutils;method=pserver;localdir=src \
- file://binutils-2.16.91.0.6-objcopy-rename-errorcode.patch;maxdate=20090801 \
- file://binutils-uclibc-100-uclibc-conf.patch \
- file://110-arm-eabi-conf.patch \
- file://binutils-uclibc-300-001_ld_makefile_patch.patch \
- file://binutils-uclibc-300-006_better_file_error.patch \
- file://binutils-uclibc-300-012_check_ldrunpath_length.patch \
- file://binutils-uclibc-gas-needs-libm.patch \
- "
-
-do_compile () {
- oe_runmake all-ld all-binutils all-gas
-}
-do_install () {
- oe_runmake 'DESTDIR=${D}' install-ld install-binutils install-gas
-
- # We don't really need these, so we'll remove them...
- rm -rf ${D}${libdir}/ldscripts
-
- # Fix the /usr/${TARGET_SYS}/bin/* links
- for l in ${D}${prefix}/${TARGET_SYS}/bin/*; do
- rm -f $l
- ln -sf `echo ${prefix}/${TARGET_SYS}/bin \
- | tr -s / \
- | sed -e 's,^/,,' -e 's,[^/]*,..,g'`${bindir}/${TARGET_PREFIX}`basename $l` $l
- done
-
- # Install the libiberty header
- install -d ${D}${includedir}
- install -m 644 ${S}/include/ansidecl.h ${D}${includedir}
- install -m 644 ${S}/include/libiberty.h ${D}${includedir}
-
- cd ${D}${bindir}
-
- # Symlinks for ease of running these on the native target
- for p in ${TARGET_SYS}-* ; do
- ln -sf $p `echo $p | sed -e s,${TARGET_SYS}-,,`
- done
-
- rm ${D}${bindir}/ar ${D}${bindir}/strings
-}
-
diff --git a/recipes/binutils/binutils_git.bb b/recipes/binutils/binutils_git.bb
new file mode 100644
index 0000000000..bf94849e77
--- /dev/null
+++ b/recipes/binutils/binutils_git.bb
@@ -0,0 +1,15 @@
+FILESPATHPKG =. "binutils-git:"
+SRCREV = "6ef128735ce52ee2acf8cfd80f6d72003dd39ab7"
+require binutils.inc
+PR = "${INC_PR}.2"
+PR_append = "+gitr${SRCPV}"
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://sources.redhat.com/git/binutils.git;branch=binutils-2_21-branch;protocol=git \
+ file://binutils-uclibc-100-uclibc-conf.patch \
+ file://110-arm-eabi-conf.patch \
+ file://binutils-uclibc-300-001_ld_makefile_patch.patch \
+ file://binutils-uclibc-300-006_better_file_error.patch \
+ file://binutils-uclibc-300-012_check_ldrunpath_length.patch \
+ file://binutils-uclibc-gas-needs-libm.patch \
+ "