aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2010-02-17 16:48:07 +0100
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2010-02-17 16:56:29 +0100
commit80db39feb76a6afaf1eb2c4dd8311fc21e4c2d6f (patch)
tree6a113d0c657fae64ff61fa7fa632fc70c7fab816
parente6472c1df7a8c76bae9b4af354f0ae6be7202cbe (diff)
downloadopenembedded-80db39feb76a6afaf1eb2c4dd8311fc21e4c2d6f.tar.gz
recipes/images/console-base-image.bb: factor out Angstrom-specific bits
* factor out Angstrom-specific bits into a separate recipe * I hope this should keep all participants in the ML-discussion happy http://thread.gmane.org/gmane.comp.handhelds.openembedded/29679 * the generic recipe now uses the IMAGE_EXTRA_INSTALL variable in favor of ANGSTROM_EXTRA_INSTALL to include additional packages in the image.
-rw-r--r--recipes/images/angstrom-console-base-image.bb10
-rw-r--r--recipes/images/console-base-image.bb9
2 files changed, 16 insertions, 3 deletions
diff --git a/recipes/images/angstrom-console-base-image.bb b/recipes/images/angstrom-console-base-image.bb
new file mode 100644
index 0000000000..2fdeecb351
--- /dev/null
+++ b/recipes/images/angstrom-console-base-image.bb
@@ -0,0 +1,10 @@
+require console-base-image.bb
+
+#Angstrom bootstrap image
+ANGSTROM_EXTRA_INSTALL ?= ""
+
+IMAGE_INSTALL = "task-base \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ ${SPLASH} \
+ ${ZZAPSPLASH} \
+ "
diff --git a/recipes/images/console-base-image.bb b/recipes/images/console-base-image.bb
index 9bd50316b5..2999d1c9c6 100644
--- a/recipes/images/console-base-image.bb
+++ b/recipes/images/console-base-image.bb
@@ -1,8 +1,11 @@
-#Angstrom bootstrap image
+# bootstrap image
+#
+# the Angstrom-specific bits that were originally part of this image
+# definition have been moved to angstrom-console-base-image.bb
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
-ANGSTROM_EXTRA_INSTALL ?= ""
+IMAGE_EXTRA_INSTALL ?= ""
ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
@@ -12,7 +15,7 @@ DEPENDS = "task-base \
"
IMAGE_INSTALL = "task-base \
- ${ANGSTROM_EXTRA_INSTALL} \
+ ${IMAGE_EXTRA_INSTALL} \
${SPLASH} \
${ZZAPSPLASH} \
"