aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-06-30 21:50:52 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-06-30 21:50:52 +0000
commit814775d0a9db1776f2bbcbe5517ed65b9a435ef9 (patch)
tree1f7e960418bae2eb8b87877535ae9ef2e222e443
parent0f691ce3239a8eb24a64610742105ad923309110 (diff)
downloadopenembedded-814775d0a9db1776f2bbcbe5517ed65b9a435ef9.tar.gz
libgmime: Packaged versions 2.2.23 (as libgmime) and 2.4.7 (as libgmime-2.4).
-rw-r--r--conf/checksums.ini8
-rw-r--r--recipes/libgmime/files/configure-cross.patch42
-rw-r--r--recipes/libgmime/files/iconv-detect.h5
-rw-r--r--recipes/libgmime/libgmime-2.4_2.4.7.bb15
-rw-r--r--recipes/libgmime/libgmime_2.2.23.bb20
5 files changed, 90 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index abbaa2de7e..b8d3352193 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -8082,6 +8082,14 @@ sha256=69d8553b351c461a8e36ed633aa2da14fdb79423b9ce0e6d3174e5ace09fadd8
md5=ed99c382471294896f576e5f77694142
sha256=39ef812217a76982947a7ac3b4a97e8303466a3dd93709366d1559e0a7ec8a46
+[http://ftp.acc.umu.se/pub/GNOME/sources/gmime/2.2/gmime-2.2.23.tar.bz2]
+md5=9f254eb989e0506243da6fde7f164998
+sha256=d5420eef50372d24eaecde93ea4c8ec55f5bf24c9e0f6abbded76e5dbd6a2d76
+
+[http://ftp.acc.umu.se/pub/GNOME/sources/gmime/2.4/gmime-2.4.7.tar.bz2]
+md5=0fb23dbb1ed6934ab577e90269cd901f
+sha256=bf75214018bb1ae82c797e79d52db2c37a8d3d9f002a737f12960fa2b1022dbd
+
[http://download.gna.org/getfem/stable/gmm-3.0.tar.gz]
md5=e543571d8812357374699491014abd58
sha256=f7fad050ce4641a43c2249fd691e514a0ee6afc09b4ec54c8c30038d0c2783d1
diff --git a/recipes/libgmime/files/configure-cross.patch b/recipes/libgmime/files/configure-cross.patch
new file mode 100644
index 0000000000..3b63d0b2e9
--- /dev/null
+++ b/recipes/libgmime/files/configure-cross.patch
@@ -0,0 +1,42 @@
+Index: gmime-2.2.23/configure.in
+===================================================================
+--- gmime-2.2.23.orig/configure.in 2008-09-14 15:28:35.000000000 +0000
++++ gmime-2.2.23/configure.in 2009-06-30 20:36:00.000000000 +0000
+@@ -169,14 +169,21 @@
+ LIBS_save="$LIBS"
+ LIBS="$LIBS $LIBICONV"
+
+-AC_MSG_CHECKING(preferred charset formats for system iconv)
+-AC_TRY_RUN([
+-#define CONFIGURE_IN
+-#include "iconv-detect.c"
+-],[
+- AC_MSG_RESULT(found)
++AC_CACHE_CHECK([preferred charset formats for system iconv], [ac_cv_have_iconv_detect_h], [
++ AC_RUN_IFELSE([AC_LANG_SOURCE([
++ #define CONFIGURE_IN
++ #include "iconv-detect.c"
++ ])],
++ [ac_cv_have_iconv_detect_h=yes], [ac_cv_have_iconv_detect_h=no],
++ [
++ AC_MSG_RESULT([cannot run test program while cross compiling])
++ AC_MSG_ERROR([Please set ac_cv_have_iconv_detect_h to yes iconv-detect.h file.])
++ ])
++])
++if test "x$ac_cv_have_iconv_detect_h" = xyes; then
++ AC_MSG_RESULT([found])
+ AC_DEFINE(HAVE_ICONV_DETECT_H, 1, [Define to 1 to use auto-detected iconv-friendly charset names.])
+-],[
++else
+ AC_MSG_RESULT([not found
+ *** The iconv-detect program was unable to determine the
+ *** preferred charset formats recognized by your system
+@@ -186,7 +193,7 @@
+ ***
+ *** Default charset formats will be used.
+ ])
+-])
++fi
+
+ CFLAGS="$CFLAGS_save"
+ LIBS="$LIBS_save"
diff --git a/recipes/libgmime/files/iconv-detect.h b/recipes/libgmime/files/iconv-detect.h
new file mode 100644
index 0000000000..714cb5aa9d
--- /dev/null
+++ b/recipes/libgmime/files/iconv-detect.h
@@ -0,0 +1,5 @@
+/* This is an auto-generated header, DO NOT EDIT! */
+
+#define ICONV_ISO_INT_FORMAT "iso-%u-%u"
+#define ICONV_ISO_STR_FORMAT "iso-%u-%s"
+#define ICONV_10646 "iso-10646"
diff --git a/recipes/libgmime/libgmime-2.4_2.4.7.bb b/recipes/libgmime/libgmime-2.4_2.4.7.bb
new file mode 100644
index 0000000000..43b1c9c0a3
--- /dev/null
+++ b/recipes/libgmime/libgmime-2.4_2.4.7.bb
@@ -0,0 +1,15 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Runtime libraries for parsing and creating MIME mail"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "glib-2.0 zlib"
+SRC_URI = "http://ftp.acc.umu.se/pub/GNOME/sources/gmime/2.4/gmime-${PV}.tar.bz2 \
+ file://configure-cross.patch;patch=1 \
+ file://iconv-detect.h"
+EXTRA_OECONF += "--disable-mono"
+S = "${WORKDIR}/gmime-${PV}"
+
+inherit autotools_stage lib_package
+
+export ac_cv_have_iconv_detect_h=yes
+do_configure_append = "cp ${WORKDIR}/iconv-detect.h ${S}"
diff --git a/recipes/libgmime/libgmime_2.2.23.bb b/recipes/libgmime/libgmime_2.2.23.bb
new file mode 100644
index 0000000000..2f2d320dac
--- /dev/null
+++ b/recipes/libgmime/libgmime_2.2.23.bb
@@ -0,0 +1,20 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Runtime libraries for parsing and creating MIME mail"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "glib-2.0 zlib"
+SRC_URI = "http://ftp.acc.umu.se/pub/GNOME/sources/gmime/2.2/gmime-${PV}.tar.bz2 \
+ file://configure-cross.patch;patch=1 \
+ file://iconv-detect.h"
+EXTRA_OECONF += "--disable-mono"
+S = "${WORKDIR}/gmime-${PV}"
+
+inherit autotools_stage lib_package binconfig
+
+export ac_cv_have_iconv_detect_h=yes
+do_configure_append = "cp ${WORKDIR}/iconv-detect.h ${S}"
+
+# we do not need GNOME 1 gnome-config support
+do_install_append () {
+ rm -f ${D}${libdir}/gmimeConf.sh
+}