aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThilo Fromm <t.fromm@dresearch.de>2010-10-01 00:25:42 +0000
committerKhem Raj <raj.khem@gmail.com>2010-10-06 15:26:54 -0700
commita10389ad4346b2285a0a5b00be893143392d8484 (patch)
treea2ef401b19099d3772cc52651175f17e473300db
parentf65559a539892959a98034cbf203145a7e22b2ea (diff)
downloadopenembedded-a10389ad4346b2285a0a5b00be893143392d8484.tar.gz
vim-7.2: remove quotes from CC in configure.in
configure.in features quotes around some calls to $CC (i.e. it calls "$CC"). CC is, however, not always just the compiler name. In OpenEmbedded CC looks more like "arm-angstrom-linux-gnueabi-gcc -march=armv5te -mtune=arm926ej-s -mthumb-interwork -mno-thumb". configure executes tests in a form like res=`"$CC" --some-arg` The shell tries to run the whole contents of the CC variable - not just the first string - as _one_ command, which will fail. However, these errors remain unnoticed during the configure run: ... configure: line 3707: arm-angstrom-linux-gnueabi-gcc -march=armv5te -mtune=arm926ej-s -mthumb-interwork -mno-thumb: command not found ... checking for setjmp.h... yes checking for GCC 3 or later... /SCRATCH/maniac/oe-merge-test/OE/tmp.6/work/armv5te-angstrom-linux-gnueabi/vim-7.2-r7.1/vim72/src/configure: line 11329: test: : integer expression expected no checking whether we need -D_FORTIFY_SOURCE=1... /SCRATCH/maniac/oe-merge-test/OE/tmp.6/work/armv5te-angstrom-linux-gnueabi/vim-7.2-r7.1/vim72/src/configure: line 11339: test: : integer expression expected no ... But finally: ... configure: creating ./config.status config.status: creating auto/config.mk config.status: creating auto/config.h So the configure step had errors, but didn't report any. This patch removes the quotes around the CC variable in configure.in. Signed-off-by: Thilo Fromm <t.fromm@dresearch.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/vim/files/configure.in_remove_CC_quotes.patch17
-rw-r--r--recipes/vim/vim.inc2
-rw-r--r--recipes/vim/vim_7.2.bb2
3 files changed, 20 insertions, 1 deletions
diff --git a/recipes/vim/files/configure.in_remove_CC_quotes.patch b/recipes/vim/files/configure.in_remove_CC_quotes.patch
new file mode 100644
index 0000000000..c8cfe8ee0d
--- /dev/null
+++ b/recipes/vim/files/configure.in_remove_CC_quotes.patch
@@ -0,0 +1,17 @@
+upstream: http://groups.google.com/group/vim_dev/browse_thread/thread/5685c3b859e3c793#
+status: reported upstream
+--- vim72-orig/src/configure.in 2010-09-29 19:13:33.000000000 +0200
++++ vim72/src/configure.in 2010-09-29 19:17:07.000000000 +0200
+@@ -35,10 +35,10 @@
+ fi
+ if test "$GCC" = yes; then
+ dnl method that should work for nearly all versions
+- gccversion=`"$CC" -dumpversion`
++ gccversion=`$CC -dumpversion`
+ if test "x$gccversion" = "x"; then
+ dnl old method; fall-back for when -dumpversion doesn't work
+- gccversion=`"$CC" --version | sed -e '2,$d' -e 's/darwin.//' -e 's/^[[^0-9]]*\([[0-9]]\.[[0-9.]]*\).*$/\1/g'`
++ gccversion=`$CC --version | sed -e '2,$d' -e 's/darwin.//' -e 's/^[[^0-9]]*\([[0-9]]\.[[0-9.]]*\).*$/\1/g'`
+ fi
+ dnl version 4.0.1 was reported to cause trouble on Macintosh by Marcin Dalecki
+ if test "$gccversion" = "3.0.1" -o "$gccversion" = "3.0.2" -o "$gccversion" = "4.0.1"; then
diff --git a/recipes/vim/vim.inc b/recipes/vim/vim.inc
index aa93527ef0..1e71d52066 100644
--- a/recipes/vim/vim.inc
+++ b/recipes/vim/vim.inc
@@ -5,7 +5,7 @@ DEPENDS = "ncurses"
RSUGGESTS_${PN} = "diffutils"
LICENSE = "vim"
-INC_PR = "r7"
+INC_PR = "r8"
SRC_URI = "ftp://ftp.vim.org/pub/vim/unix/vim-${PV}.tar.bz2;name=vim${PV}tarbz2 \
ftp://ftp.vim.org/pub/vim/extra/vim-${PV}-extra.tar.gz;name=vim${PV}extratargz \
diff --git a/recipes/vim/vim_7.2.bb b/recipes/vim/vim_7.2.bb
index 6807bd2473..7d74d08256 100644
--- a/recipes/vim/vim_7.2.bb
+++ b/recipes/vim/vim_7.2.bb
@@ -15,11 +15,13 @@ PR = "${INC_PR}.2"
# 001-411.diff contains 411 patches fetched from upstream
SRC_URI += "file://001-411.diff;apply=no"
+SRC_URI += "file://configure.in_remove_CC_quotes.patch;apply=no"
# we need to apply patches in other dir then ${S}
do_applypatch() {
cd ${WORKDIR}/vim${VIMVER}
patch -p1 <${WORKDIR}/001-411.diff
+ patch -p1 <${WORKDIR}/configure.in_remove_CC_quotes.patch
}
addtask applypatch after do_unpack before do_patch