aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-11-11 21:50:16 +0100
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2010-11-11 22:07:45 +0100
commitac36d86725da867d691b16668d88f096d0b7da37 (patch)
tree194e107681bf63d2b080071b27c2dd5565c019e7
parentdc1e3efb70aeae1979e403defc2ec42c3481931c (diff)
downloadopenembedded-ac36d86725da867d691b16668d88f096d0b7da37.tar.gz
libsdl-mixer 1.2.11: fix libvorbis's search path
without that patch configure outputed something like this: checking tremor/ivorbisfile.h usability... yes checking tremor/ivorbisfile.h presence... yes checking for tremor/ivorbisfile.h... yes checking for ov_open_callbacks in -lvorbisidec... no configure: WARNING: *** Unable to find Ogg Vorbis Tremor library (http://www.xiph.org/) configure: WARNING: Ogg Vorbis support disabled Then digging into the configure script made me found that: LIBS="-lvorbisfile $LIBS" just before the compilation of the test(the following output comes from config.log): configure:11947: arm-oe-linux-gnueabi-gcc [...] -o conftest [...] conftest.c -lvorbisfile -L/usr/lib -lmikmod -ldl -lm >&5 /usr/lib/libvorbisfile.so: file not recognized: File format not recognized collect2: ld returned 1 exit status configure:11947: $? = 1 we clearly see -lvorbisfile -L/usr/lib ./configure --help says: LIBS libraries to pass to the linker, e.g. -l<library> so I simply overwritten LIBS in the recipe in EXTRA_OECONF The result was tested on nokia900 with wesnoth-wvga: Before it couldn't play its ogg vorbis music, and now it can. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.11.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes/libsdl/libsdl-mixer_1.2.11.bb b/recipes/libsdl/libsdl-mixer_1.2.11.bb
index 1d5b1f9d08..8c032ceb03 100644
--- a/recipes/libsdl/libsdl-mixer_1.2.11.bb
+++ b/recipes/libsdl/libsdl-mixer_1.2.11.bb
@@ -4,7 +4,7 @@ PRIORITY = "optional"
DEPENDS = "virtual/libsdl flac libmikmod libvorbis libmad"
LICENSE = "LGPL"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \
file://fix-flac-madness.diff"
@@ -20,7 +20,7 @@ inherit autotools
# Add support for runtime linking with libmad so we can use that for fixed point MP3 decoding.
# Add support for runtime linking with libtremor so we can use that for fixed point OGG Vorbis decoding.
-EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor --enable-music-mp3-mad-gpl"
+EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor --enable-music-mp3-mad-gpl LIBS=-L${STAGING_LIBDIR}"
do_compile() {
# Override SDL_LIBS to include a linker rpath so the linker